How to eliminate Event code 3036 warning

Moondoggy

Extraordinary Member
#1
My Windows 7-64-bit machine is reporting an event 3036 warning each time the WSearch service is started. Although benign, I would like to be able to fix this issue. I have searched the internet for a solution and have come up empty handed Here are the details:

Event type: Application
Source: Search
Event ID: 3036
Level: Warning
Event Source: Windows Search Service
Context: Application, Systemindex catalog
Details: The object was not found. (HRESULT : 0x80041201) (0x80041201)
The content source csc://s-1-5-21-287814290-815585838-4093042447-1000 cannot be accessed

If anyone knows how to eliminate this event, please let me know.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Have you done a search for the s-1-5-xxxx folder? You may have to enable hidden and system files to find it, not sure. It looks to me, and certainly not an expert, something is searching for a file or folder inside that location and cannot access it.

You might also check the control Panel-Indexing Options and see if anything looks familiar or if you can redo the index.
 


Moondoggy

Extraordinary Member
#3
OK. I have a work around but I don't believe it's a fix.

On another forum site someone said that the CSC in the event stood for "Client Side Caching" and that if I turned off indexing of Offline Files then the warning message would go away. It did.

I'm still a bit perplexed by the event and perhaps someone can shed more light on this. From what I gather if you do want to work on off-line files then a copy of the file would be stored somewhere on my PC which I assume to be the C:\Windows\CSC folder and the way I had it set up before the search service was attempting to index any offline files stored in that folder. I would also "assume" that it you have never had a need to work with offline files then the CSC folder would be empty therefore nothing to index. But, the warning was not that there was nothing to index the warning was that something could not be accessed. What I'm "assuming" is that the underlying problem still exists and that it I found the real cause of the access issue then the step taken to turn off caching of offline files would be unnecessary. So, even though I have a work around I would really still like to determine what the issue is so if anyone has any next steps I'd appreciate the help.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Well, as I said I am not an expert, but it appears you did not respond to my post.

So, all I might suggest is to go into the control panel and look under indexing and add the CSC folder to the indexing options.

Secondly, the file that seems to be causing problems is probalby in the:

Users\You\AppData\Roaming\Microsoft\Protect folder.

You might try adding that to your index, or try to find out why it is being (or not being) accessed.

And lastly, in the indexing panel, you can rebuild your index. Perhaps that would remove the possible corruption in the index data base.
 


Moondoggy

Extraordinary Member
#5
I have a solution but I''m not sure that I understand why things were the way they were.
To make a long story short I tried drilling down into the CSC folder and in the only subfolder in CSC I was denied access but when I looked at the security it said that there wasn't even an owner of the folder so I took ownership. I then drilled down into that folder and found 2 more folders that had no owners either so I took ownership of those two. Note that taking ownership was the only thing I did. I then when back into the indexing function in control panel, turned on indexing on the off line folders restarted my system and NO Warning. Seems that no ownership was the issue which I'm not not going to try and figure out because I won't find an answer to that anyway.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.