How to grant 'permanent' permissions.

#1
I'm slowly but surely starting to enjoy this learning experience.
And this forum is playing a good sized part in that.
I'm a cranky little old man who has finally given up on XP Pro.
I was never good at it-I'm still a novice-but I was able to deal with most problems on my own.
Now I have W7 Pro installed as a fresh install over XP. After the install I deleted the 'old files' because I want to set this up differently.
I use a Gigabyte UD3 P45 motherboard with an E8400 and 4g's RAM on a 32 bit system.
Every time that I start or restart the pc I get a pop up that asks if I want to let Gigabyte make chages to my pc.
The answer is yes.
However, I can't have this all the time. I also have a UPS power backup that is set to shutdown the pc before the battery goes dead. That's not the time to have your ask pc if you think it's a good idea. Especially if I'm not home when there is a power outage.
So how can I set these permissions so that I don't have to worry about this?
Thanks for a great forum and any help.
J
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#2
I would think something like that would be controlled in the Bios.

Do you have it set for a PnP OS installed set in the bios?

When exactly does this pop-up occur?
 


#3
I'm pretty sure that what needs to be done is to manipulate the User Account Control.
I just don't know how to get past the screen with the slider. I don't want to give easier access to anything other than the few programs that I decide on.
Thanks.
J
 


#4
I wonder what's calling the Gigabyte message to come up? Is there something loading at startup?
Run Msconfig and go to startup and see if there is a box you can uncheck.
 


#5
TBlount,
What was trying to run was the GUI MFC application. There are known issues with Gigabyte's ET5 & 6 that cause the problems I was having.
Deleting ET6 wasn't enough.
I had to go to msconfig, startup and uncheck the guimfc.
Would be nice if Gigabyte would fix that.
However, my original question still holds.
How do we grant individual permissions in W7 so that we don't have to turn off UAC.
Thanks for your help.
J
 


#6
I don't know... I have killed/disabled anything that would slow me down and ask permission. It's my compuer I don't need permission to do anything.

However I have noticed that if you right click on a shortcut you have an option to "run as administrator" and that apparently overrides the default UAC setting.... However I guess you would need something like a rubber band to hold down that option all the time if you want to do it without manual intervention.

If you really really want to automate it... you can use a program like keytext that will run a macro and do anything you want at any time you want.
 


RAK

Extraordinary Member
#7
You can enable the Global Administrator account, but this will still leave the vulnarability that is bothering you, as it is tantamount to turning off the UAC. If you are still interested:
There are a couple of ways:
Open a command prompt( Right click - Run as Administrator).
Type the following command and enter.
net user administrator /active
Log out and see if you have a new alternative login, as well as your existing one. If not, do it the long way.

Shut down the computer for a cold boot. Tap the "F8" key as you are booting.
Select "Safe Mode with networking" from the boot menu.
Log into windows 7 with your personal account that holds the administrator access.
Open a command window (START--->RUN--->CMD.exe). At the command prompt type the following net user administrator /active
Log out and log back in as administrator.

Another way
Go to Start
Type Control UserPasswords2.
Click Advanced.
Click Advanced again.
Select Users.
Select Administrator and untick the the box “Administrator is disabledâ€Â￾
Now log out and login as Administrator.
AS i SAID,TThe action leaves you a little more vulnerable to outside attack. Not a big issue if you are confident with your anti virus control etc.
.
 


#8
I think he wants to allow one program higher access and keep the UAC more restrictive on the rese of the system. .. like Individual Access levels for individual files.. rather than global.

At least that's my understanding because this started out as an annoyance by an access prompt for something related to his graphics card.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#9
How do we grant individual permissions in W7 so that we don't have to turn off UAC.
Thanks for your help.
First a comment, I just saw a thread where someone could not get the Windows Experience Index to complete a check. He had a Gigabyte board and had to update the Bios.

Anyway, how about a specific example of what you want to do using a folder or program or whatever? What permissions do you want to bypass and where are you asked for those permissions?
 


#10
Its in his first message.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.