How to remove microphone echo Windows 7

Discussion in 'Windows 7 Help and Support' started by Kavalera, Dec 31, 2009.

  1. Kavalera

    Kavalera New Member

    Joined:
    Dec 31, 2009
    Messages:
    6
    Likes Received:
    0
    Hi when i connect microphone to my notebook and I make karaoke In speakers is some echo with my voice. Can you help me how to remove this echo. In XP there is no echo.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,841
    Likes Received:
    1,568
    Hi,
    have you tried checking the settings via the control panel? I'm not running a mike otherwise you would see it listed in the box I've got arrowed but you should have, so see if you can 'tweak' it...
     
  3. Kavalera

    Kavalera New Member

    Joined:
    Dec 31, 2009
    Messages:
    6
    Likes Received:
    0
    The problem is that when i speak to microphone i hear in the speakers but with echo and i want to remove this echo. Can you help me
     
  4. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Fighting the echo :

    1. Try lowering the mic sensitivity in windows control panel (see kemical's post above)
    2. Move your mic some distance away from the source of sound
    3. Check your sound card manufacturer's site for any special software designed to record from mic
    4. There is commercial software that filters out completely or reduces this echo effect
    5. Professional more expensive mics generate less echo effect
     
  5. Kavalera

    Kavalera New Member

    Joined:
    Dec 31, 2009
    Messages:
    6
    Likes Received:
    0
    I have this problem only with Windows 7 or Vista. With XP there is no problem. So I have to search other way to resolve the problem. Can you tell me Software for filter and reducing of echo.
     
  6. Voldemort

    Voldemort New Member

    Joined:
    Feb 5, 2010
    Messages:
    6
    Likes Received:
    0
    Disabling echo in win7 ?

    Well, she is not talking about feedback from the speakers. There is a software feature in Win7 that adds echo to your voice when you sing into the microphone wich is not a good thing when you are doing karaoke as it adds lag and distorts your voice so how can it be disabled ?
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Voldemort:
    Hello and welcome to the forums. The software feature, that you are talking about, is probably not actually in Windows 7 but is more likely a product of third party software that comes with the installation of the driver package for a lot of sound cards. Mine is from Realtek and is called HD Audio Manager and the effects can be found under the effects tab, see attachment. So depending on your sound card and it's driver / software package you will need to look there, start in control panel small icons view and look around.
     
  8. Voldemort

    Voldemort New Member

    Joined:
    Feb 5, 2010
    Messages:
    6
    Likes Received:
    0
    Thank you very very much for your quick reply :)
    The thing is I´m a very experianced computer user and I´ve been all over the Creative drivers and driver settings and I can´t find a way to disable the echo, it has to be in Windows ? I´ve disabled all sound effects using the Creative control board to no avil.....I´m lost :)
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Try this, right click on the speaker icon, down near your clock in the system tray area and choose, open volume mixer, in the resultant window click the speaker icon between the words device and speakers, in the resultant window look to see if you have anything like an "Enhancements" tab, if so select it and choose disable all sound effects. Keep us posted.
     
  10. Voldemort

    Voldemort New Member

    Joined:
    Feb 5, 2010
    Messages:
    6
    Likes Received:
    0
    Thank you for your suggistion, but I already tried that..........this is some hidden feature and all I can do is connect my speakers to my old xp driven computer :/
     
  11. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Couple of suggestions, first right click the speaker icon, select recording devices, highlight your mic, and configure-set up microphone. Maybe selecting a different type of mic might help. Under properties, there may be a setting you could use.

    I also have an IDT icon in the tray. If you have this, open the audio control panel. Recording, front or rear mic, Microphone boost.

    This assumes there is not a setting in the Karaoke utility for such a thing.
     
  12. nellanayrb

    nellanayrb New Member

    Joined:
    May 29, 2010
    Messages:
    2
    Likes Received:
    0
    Under the microphone properties in Windows 7 on the Listen tab there is an option "Listen to this device". Turn that off and the echo should go away. I had the same problem and unchecking this "feature" fixed it.
     
  13. Steve Marks

    Steve Marks New Member

    Joined:
    Jan 30, 2014
    Messages:
    1
    Likes Received:
    0
    I had the same problem and this fixed it. THANKS!
     

Share This Page

Loading...