How to set read only permission on all photos for all users

Discussion in 'Windows 7 Help and Support' started by Shumboom, Jan 12, 2012.

  1. Shumboom

    Shumboom New Member

    Joined:
    Dec 31, 2009
    Messages:
    74
    Likes Received:
    0
    Hi

    I have just moved all my photos to my NAS and I want to set read-only on them as my whole family are accessing them. I though this would be simply the case of clicking the read-only attribute for the folder but I can still delete the files.What should I be doing?

    thanks,Shumit
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    When you set the folder to Read Only, did you get the popup that asked about setting it for the folder only or all the folders and files?

    Are the other users admins also?

    I just made sure the file was read only, but of course I could delete it because I was the owner.
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Without knowing how you and others are actually accessing the NAS (browsing to network share or shortcut, mapping a network drive, etc.,) and what format (Fat32 or NTFS) the NAS drive(s) are it is difficult to suggest how you might proceed.
    If NTFS you will likely have to edit the NTFS Permissions (Security Tab) in the properties of the folder, individually per user, in the properties of the parent folder by clicking the Advanced button there. And in order to do this successfully you will likely need to break inheritance of that folder from its' parent container by clicking the Change Permissions button and unchecking the box that says Include inheritable permissions from this object's parent (be sure to click the Add button when prompted and not the Remove button or you'll be left with adding back in all your users and groups)
    Then you should be able to edit the individual NTFS Security Permissions as you desire (Do not mess with accounts you do not want to manage like SYSTEM or NETWORK, etc., leave them as is).
    You can add users or edit existing user permissions from there and for your read only guys you'll want to Allow:
    Read Permissions, Traverse folder / execute file, List folder / read data. Make sure you leave one account, presumably yours with full permissions (otherwise you are going to have to go back and take ownership of the folder and start over) and make sure you check the box at the bottom that says Apply these permissions to objects and or containers within the container only. And if you are going to want other to be able to save images to this container they are going to need write permissions, Create Files / Write Data and Create Folders / Append Data.
    Perhaps if you are only looking to protect the files and folders from accidental or malicious deletion then an explicit deny check (Delete and Delete subfolders and files) might work better for you, although I have never found it too beneficial to use explicit denies when setting NTFS Permissions.
    And you'll want to make sure that no one other than yourself has Change Permissions and Take Ownership to the container.
    This is not simple or easy and can result in unintended consequences if not done properly. That's why I normally suggest using a test folder with a single image in it and performing the above action on that folder and determine if the results are as you expect.
    Regards
    Randy
     
  4. Shumboom

    Shumboom New Member

    Joined:
    Dec 31, 2009
    Messages:
    74
    Likes Received:
    0
    Wow this looks so complex! All I want is to make the files look as if they are on dvds, ie even I would not be able to accidentally erase the files unless i explicitly changed permissions on the files.

    In answer to your questions the NAS is NTFS and I have mapped it as the Z drive. I will have a go at your 'deny' solution on a temp folder in the meantime.

    thanks,Shumit
     
  5. Shumboom

    Shumboom New Member

    Joined:
    Dec 31, 2009
    Messages:
    74
    Likes Received:
    0
    Just tried most of these settings for 'everyone' and absolutely nothing works. Whatever permissions I set look as if they have taken effect but when I return to properties there are no settings applied.

    It works fine on my computers' hard drive so it is a NAS related problem. Should I look at icacls?
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Have you looked into the differences between file security and file sharing?

    Also, when you check if it is working, get another user to do that.
     
  7. Shumboom

    Shumboom New Member

    Joined:
    Dec 31, 2009
    Messages:
    74
    Likes Received:
    0
    Sorry but what should I be looking at - file sharing or file security?

    I want access to the pictures to be read only for myself as I want to prevent myself or anyone using my computer from accidentally deleting the files. This all works fine on files on my local drives.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I don't have a NAS to test, but which one do you have? Does it come with any software to control access or is it like Windows?
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If the NAS is truly an NTFS volume and it must be because otherwise (fat32) you wouldn't have a security tab in the folder properties. Then setting NTFS permissions should be all you need to do. When share permissions and NTFS security permissions are combined the most restrictive one applies and an explicit deny over rules any and all allows and wins everytime.
    You can read this for a more in-depth explanation.
    TechExams.Net - MCSA/MCSE 70-290 TechNotes: Shared Folder and NTFS Permissions
     
  10. Shumboom

    Shumboom New Member

    Joined:
    Dec 31, 2009
    Messages:
    74
    Likes Received:
    0
    It is a dlink - dns 323 set up with RAID 1 - it comes with some software to set it up but not for setting up permissions etc. I have it mapped as my Z drive so I use it from windows. I have looked on the relevant forum and most people are talking about linux permissions. If I cant get my answer here I will post there but Im not sureI'll understand the answer.
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    As Saltgrass has already mention, many such devices come with a Web Interface for configuration.
    I would suggest looking more closely at that and perhaps the Device's Forum Boards regarding permissions
    DNS-323
    Search for permissions
     
    #11 Trouble, Jan 13, 2012
    Last edited: Jan 13, 2012

Share This Page

Loading...