How to Share Documents Folder on Workgroup

Discussion in 'Windows 7 Networking' started by jmdennis, Jun 13, 2012.

  1. jmdennis

    jmdennis Senior Member

    Joined:
    Jun 8, 2012
    Messages:
    14
    Likes Received:
    0
    I've searched this online, but the solutions I found do not work so hopefully someone can shed some light on this.

    Scenario:
    In our office, all of our pc's are on a wireless network, have either Windows 7 Pro or Ultimate, and are all assigned to Workgroup: "OFFICE". I have 2 pc's at my desk, call them 'A' & 'B', and I need to share the 'Documents' and 'Pictures' folders between them. I do not want to share these folders with any other employees on our network.

    What I Tried:
    If I open Explorer, right-click on the 'Documents' folder, click 'Share with', click 'Specific People', my user account 'Jack' is the only one displayed. When I click the drop-down, it only lists 'Jack', 'Everyone', and 'Create new user'. When I searched this topic online, I read that all User Accounts assigned to our Workgroup should be listed here in the drop-down, but they are not. Both of my pc's are turned on and connected to the wireless network so it should at least display both of my user accounts in the drop-down, right?


    Thanks in advance!
     
  2. PhilipW

    PhilipW New Member

    Joined:
    Jun 8, 2012
    Messages:
    46
    Likes Received:
    0
    A couple of things about Sharing.
    1) if you want to create a hidden share then when you share a folder add the $ at the end of the name. E.G. Docs$
    2) you have to have permissions on a share. If you give "Everyone" permission than anyone can get on that folder. "Everyone" does not show up as someone you can click on. But if you type it in you can use it.
    3) However you are talking about not sharing with any else in the network. To do that you have to use a local user account and give that account both Security & Share Permission to a folder. In my case, I use a workgroup at home. I have a local account on both machines called "Philip" I give the Philip account permission to the Share. Then I go to the other PC and either map a drive for a permanent connection or I use the run command for a temp connection. In the run command and in the map drive I use "\\OtherPC\Share$" when it asks for user name and password I use Philip and Password. Because the share is hidden, no one else can see it and if they found out about it they would still need the password. In mapping the drive you need to click the check box that says "Connect using different credentials"
    Hope that helps
    Philip
    Network Administrator, MCSE, MCSA, CCNA
     
  3. jmdennis

    jmdennis Senior Member

    Joined:
    Jun 8, 2012
    Messages:
    14
    Likes Received:
    0
    Right. I have a User Account "Jack" on both of my 2 pc's similar to you. I understand I need to give the 'PC-A/Jack' user account permission to access the 'PC-B/Jack' folders and vice versa, but I have not been able to do this so far.

    When I am on PC-A and I right-click the 'Documents' folder, go to 'Share with' > 'Specific People', my problem is the 'PC-B/Jack' user account is not listed there so I cannot select it and give it permission to share. When I am on PC-B and follow the same steps, the PC-A account is not listed so I cannot select that one either.

    On your home workgroup, if you go to 'Share with' > 'Specific People', do you see the user accounts from both of your pc's?
     
  4. PhilipW

    PhilipW New Member

    Joined:
    Jun 8, 2012
    Messages:
    46
    Likes Received:
    0
    I think the problem is you are clicking on "Share" from "Sharing" tab.
    Click on "Advanced Sharing" instead.
    Click the check box next to Share this folder
    Then click on Permissions
    I think it is easier to add users here.
    Also, you must choose a account that is local to the PC you are sharing from. In my case, both machines have a Philip. So I click add, then type in Philip then OK.
    Then go back and give Philip at least "change" permissions.
    Also you can not give "PC-B Jack" permission to use PC-A shares, not in a workgroup.
    You need to give "PC-A Jack" permission to "PC-A" Shares.
    But if "PC-A Jack" and "PC-B Jack" both have the same user name and the same password you may not even need a password when connecting. And if does ask you for account creditials you should be able to just type in Jack and the password. Most of the time that will be enough. If it is still having a problem you may need to type in PC-A\Jack and the password to connect to \\PC-A\Share. But the PC account is the account on the PC that is doing the sharing not the viewer.
    Does this answer your question?
     
  5. jmdennis

    jmdennis Senior Member

    Joined:
    Jun 8, 2012
    Messages:
    14
    Likes Received:
    0
    Philip,

    I did get it to work finally. I was using the "Share With" menu in Explorer and also in the Right-Click menu. When I right-click on the 'Documents' folder and click Properties, I was able to find the 'Advanced Sharing' option. I followed the steps you provided there and it worked perfect. I still do not understand why the "Share With" process did not show user accounts from our Workgroup as the Microsoft website explains this is what should happen. Nevertheless, it works now.

    I do have the same login and both computers and I do not have to type in the username/password. I simply open Explorer, click Network, and there is my share.

    Thanks!
     
  6. PhilipW

    PhilipW New Member

    Joined:
    Jun 8, 2012
    Messages:
    46
    Likes Received:
    0
    I'm glad you have it working. It seems to me the Advanced Sharing is easier to use too. Go figure.. :)
     

Share This Page

Loading...