HP Deskjet 6980 duplex unit

Discussion in 'Windows 7 Help and Support' started by mUNLtiJ0, Aug 3, 2009.

  1. mUNLtiJ0

    mUNLtiJ0 Honorable Member

    Joined:
    Jul 25, 2009
    Messages:
    4
    Likes Received:
    0
    Help!

    My HP Deskjet 6980 duplex unit (which turns over pages automatically) does not turn over pages since I changed to W7. I downloaded the latest Vista drivers (had to run installer in compatibility mode). The option to use auto duplex unit is greyed out. Printer works fine otherwise...except I have to turn pages now BY HAND!! :eek:

    W7 is great otherwise.

    Come on HP!!
     
  2. bmclachlan

    bmclachlan Senior Member

    Joined:
    Jul 3, 2009
    Messages:
    6
    Likes Received:
    0

    I previously had an HP 7300 unit and when switching from Windows XP to Vista ultimate (32-bit) I found the duplexer not working as well. I stumbled upon a driver that a Microsoft employee had access to (I think as I remember the story, the HP employee residing on the Microsoft campus had written it but the new driver was not getting any approval traction in HP). The Microsoft employee was nice enough to share an FTP link and the driver worked perfectly.

    So you might try perusing the MSDN forums to see if you can get as lucky as I did. I was really quite upset at HP for not providing such support. As an aside, I now have a similar problem as I have purchased a new HP 8500 with no real driver support from HP for a Windows 7 at this point. Luckily, Windows does recognize it as a printer and allows me basic printer support.
     
  3. Slambert

    Slambert New Member

    Joined:
    May 26, 2010
    Messages:
    2
    Likes Received:
    1
    I've Got The Anwser

    Start by deleting your printer.
    The when you want to connect it again make sure to update the drivers from Windows Update.
    It doesn’t matter if you connect it through Lan, WiFi or USB.
    When the printer is connected, dubbel click it, now choose “customize your printer “
    Click the tab “Device Settings”
    Locate Duplex…. In the list, and set it to Active or Installed.
    Might also be a good idea to deactivate manual Duplex.
    Klik OK, close the printer window, and You are all set!

    Hope this helps
    Regards from Denmark ;)
     
    bassfisher6522 likes this.
  4. Wally

    Wally New Member

    Joined:
    Dec 6, 2010
    Messages:
    2
    Likes Received:
    0
    Re: I've Got The Anwser

    Thank you Slambert your solution works superbly.

    I lost an hour of my life trying to solve this and even wasted my time looking at HP.com for a clue. Can I suggest you forward your solution to HP and request that they provide you with a years supply of cartridges as a reward for saving their much valued clients years of their valuable time! (British sense of humour)

    Cheers....
     
  5. John Hamilton

    John Hamilton New Member

    Joined:
    Oct 20, 2013
    Messages:
    1
    Likes Received:
    0
    I have spent several hours trying to figure this out. HPs site is worthless. A bunch of other so-called expert sites wasted my time. And I found this at last.

    Thanks so much for the only correct answer on the internet, afaik!
     
  6. Ceri

    Ceri Member

    Joined:
    Sep 15, 2016
    Messages:
    1
    Likes Received:
    0
    This worked for me too. One pointer for anyone who's going to try this: when you update the drivers (a) expect it to take A Very Long Time ("a few minutes" my foot). Also (b) when it does there are three different categories to check "Hewlett Packard", "Hewlett-Packard" and "HP" - the Deskjet 6980 series drivers are in the HP category.
     

Share This Page

Loading...