HP5150 driver with Win7 not working properly

#1
before i purchased win7, i made sure that my peripherals would connect and run okay. i discovered that my HP5150 printer needed drivers but that they were included on the CD...supposedly.

brought my new computer home and tested things out. found out that the cuplexing feature doesn't work like it should.
eg. i selected to print a 6pg document. i clicked all the correct settings. my printer printed pgs 1,3, and 5.
then the pop box guided me to take pages out of printer and re insert them in opposite direction. that was fine.
except there was page in the printer half printed and just sitting there preventing me from inserting my pages to be printed on others side. i discovered that this half printed page was actually half of pg 2...that had already started printing.

something is not working here. it used to work just fine when i used XP.

can anyone help me out here.
i have seen where one can download win7 drivers for HP5150, but am hesitant to do so as i don't want to interfere with the update drivers that we supposed to be on the cd setup of win7.
 


#2
Hi cooky09,

Sorry we're so late in getting to this. Hopefully you've solved the issue by now, but in case not -- here is the official HP page with information about using your HP5150 printer in Windows 7: Installing the Product with the USB Cable and Using the Driver Located in the Windows 7 Operating System HP Deskjet 5150 Color Inkjet Printer - HP Customer Care (United States - English)

Let me know if you have any other questions!

Cheers,

Walker
Windows Outreach Team
 


#3
Hi cooky09,

Sorry we're so late in getting to this. Hopefully you've solved the issue by now, but in case not -- here is the official HP page with information about using your HP5150 printer in Windows 7: Installing the Product with the USB Cable and Using the Driver Located in the Windows 7 Operating System HP Deskjet 5150 Color Inkjet Printer - HP Customer Care (United States - English) Walker Windows Outreach Team
no i had not solved my problem yet. with regard to maybe working around the tool box feature, i will work on.

but there is no mention of the duplexing problem...i spelled it incorrectly in my post.
is there a work around for this?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.