Huawei E173 not installing under Windows 7 Ultimate 64-bit Service Pack 1

#1
I can't install Huawei E173 under Windows 7 Ultimate 64-bit Service Pack 1. I get the following message:

Greška prilikom instalacije Huawei E173 T-Mobile.png

"Upravljački program nije pronađen" in the screenshot means "Driver not found".

I have also tried connecting the modem while connected to the Internet, to no avail.

I had previously installed and used 3 other USB mobile broadband modems on the same system, 2 of which were Huawei. All software for these modems is supposed to be uninstalled.

However, when I install it under a VMware virtual machine with a fresh install of the same operating system, everything works fine.

I have also tried copying all relevant drivers successfully installed under the virtual machine to the physical machine, but that doesn't completely work, either.

How can I solve this problem?

I will pay $10 via PayPal to anyone who provides the solution.
 


#2
Maybe the problem is with SP1, are the virtual machines where this modem works perfectly good also running SP1?
 


#3
This problem already got solved by itself after Microsoft offered some new updates for Windows 7.

You are correct: the physical machine had Service Pack 1 installed, while the virtual machine didn't.
 


#4
Can you tell exactly which update fixes the problem to help other people with the same problem?
 


#5
Don't know; however, running Windows Update and installing all available important, recommended, and optional updates (excluding language packs) fixes the problem. The update that fixed the problem was released about two months ago.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top