Windows 7 I want to run Gadgets in 32-bit instead of 64-bit

#1
I am trying to use the Pandora Gadget and want to run it in 32-bit instead of 64-bit. How do I do that?
 


reghakr

Essential Member
#2
So you've installed the 64-bit version on Windows7, right?

You'll have to download the 32-bit version and overwrite your 64-bit version. OK, just kidding.

When you right-click on the Desktop, how many gadgets show up in the list?

Can you add any other gadgets to the desktop?
 


#3
Haha, man that would've sucked. Well all my gadgets show up on the list, so that would be 11 gadgets. I found the 32-bit version of the gadget in my files, but I don't know how to make it run on startup.
 


reghakr

Essential Member
#4
Great, glad you located it.

Do all other gadgets load on startup with the Pandora gadget being the except?

Are all gadgets located in the C:\Program Files\Windows Sidebar directory. It also may be due to a missing .xml file for your gadget.

By the way, what is the Pandora Gadget?
 


Last edited by a moderator:
#5
Yes, all the other gadgets load up. The only problem is they all load up in 64-bit. So it's a hassle to open up the Pandora 32-bit separately each time I power on the computer. Is there any way to have the 32-bit version start at startup, instead of the 64-bit?

Thanks
 


reghakr

Essential Member
#6
Are you running the 64-bit version of Windows?
 


#7
Yup, I installed the 64-bit version of Windows 7.

I figured might as well get a head start on the 64-bit revolution, right?
 


reghakr

Essential Member
#8
If you're running 64-bit edition, you need to use 64-bit gadgets.

Did you read my previous post regarding what directory it is located in and about a missing xml file?
 


#9
Yup, I did, but that's not the problem. The problem is the gadget uses Flash, and Flash is not made to run in 64-bit yet. So I have to run the gadget in 32-bit to make it work. I was able to do it easily in Vista, but I can't figure it out in Windows7.

The Pandora gadget connects to pandora.com. It's a free radio that fins songs for you based on your preferences. It's pretty awesome, I suggest you try it out.
 


reghakr

Essential Member
#10
Yes, your correct, Flash does not work in 64-bit, and I don't believe you'll get it to run correctly on Windows7

You could always shoot off an e-mail to them and see if they have any suggestions.

Yes, Pandora is incredible. My PC came with a link to Pandora radio.

Is the gadget located on their site?
 


#11
same problem

hey im having EXACTLY the same problem. anyone got a solution...?
 


#12
solution.

well you can go to regedit

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings

and create DWORD and name it AllowElevatedProcess,

then double click it and change the value to 1.

since the DWORD runs on 32bit. it will run all the gadgets.

let me know how it goes.
 


#13
didnt work

thnx for the suggestion but i tried it and it didnt work. i dont think windows 7's gadgets go through sidebar anymore...
 


#14
There's a 64-bit version of flash out there from Adobe. I mean, if they released a 64-bit version for Linux, there should be one for Windows.
 


reghakr

Essential Member
#15
It should be coming soon, and I'll bet it's out before the final release of Windows 7.

take a look at these sites:
bit-tech.net | Adobe previews 64-bit Flash

iTWire - Adobe to introduce Flash Player for 64-bit and mobile systems

Also, if you're having problem with the 32-bit gadgets, this is the correct registry script:

This registry script works on the 32-bit preview version, not sure about the new build.

Copy and paste the following in the quote area into Notepad, and choose Save As, click the drop-down menu for All files and manually type in the extension .reg. Now double-click on that file to import it into the registry.
Note: If there are any spaces between any lines, correct them so there are no spaces. Curr ent, should read Current

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Compatibility]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings]
\"SidebarDockedPartsOrder\"=\"0x1,0x2,0x3,0x4\"
\"AllowElevatedProcess\"=dword:00000001
All ten gadgets worked on my machine
 


deus

Senior Member
#16
Hello..

Ok, so i absolutely love that gadget, so i did a similar think that they suggest here:
http://www.bgreco.net/gadgets/pandora/64.php

Then disabled the standard (64 bit) gadgets from being run as shown here:
http://www.itechtalk.com/thread3860.html

Then dragged the sidebar.exe from (your_drive:\Program Files (x86)\Windows Sidebar) to the startup folder and ran it.... Then just reinstalled the pandora gadget from their website (http://www.pandora.com/on-windowsgadget)

I hope this works for you too.

-Dane
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.