Icon Problem word 2007

Discussion in 'Windows 7 Software' started by Pepa, Mar 16, 2012.

  1. Pepa

    Pepa New Member

    Joined:
    Mar 16, 2012
    Messages:
    10
    Likes Received:
    0
    I almost just received my brand new PC, and I installed Microsoft Office Student and Home Edition 2007 and uninstalled the 2010 starter edition. The problem is that the icons of word do not show as they should. There is a blank white page with the sign of word in the middle. It opens up fine but it is annoying. In the properties the type of file is DOC instead of Microsoft Office Document. Also, I noticed it only does that with the documents that are saved as to be compatible with previous versions of word, while the docx files icon appear correct. It is not exactly missing icons, so I don't think it has to do with the icon cache. I would appreciate any help.
     
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    If you completed the install and removal in the order you indicated it may have caused a problem. I would have removed the 2010 trial before installing the 2007 version. Try removing the 2007, running a cleanup and the reinstalling the 2007.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    There is probably an option to repair 2007 in Programs and Features.
     
  4. Pepa

    Pepa New Member

    Joined:
    Mar 16, 2012
    Messages:
    10
    Likes Received:
    0
    I tried both. Didn't work.:(
     
  5. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Try right clicking on one of the problem document icons, select "open with"click on "choose default program". Click on browse and navigate to some other program like notepad. Click all the way back out. Repeat the process but this time select Word 2007 to open it with. It will probably re-associate the Word icon.
     
  6. Pepa

    Pepa New Member

    Joined:
    Mar 16, 2012
    Messages:
    10
    Likes Received:
    0
    Unfortunately didn't work.
     
  7. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Run regedit and navigate to this key:

    HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \Extensions

    Look to see if both .doc and .docx extensions are listed in the right panel
     
  8. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Also try this editor:

    Default Programs Editor

    Select file type settings, Icon, search for "microsoft word".
    Highlight the entry for .doc, click on next.
    Click on browse and select the icon you want to use.
     
  9. Pepa

    Pepa New Member

    Joined:
    Mar 16, 2012
    Messages:
    10
    Likes Received:
    0
    Didn't work. It shows the correct icon on the Editor but it doesn't fix the problem. But I fixed it with Types by copy/paste the correct location for icons from the docx that work fine and then choosing the correct icon for doc. Thank you all for your time. :redface:
     
  10. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Glad it's sorted and thanks for the feedback.
     
  11. alexandervs

    Joined:
    Mar 31, 2012
    Messages:
    24
    Likes Received:
    0
    romve and reinstall a new vesion
     

Share This Page

Loading...