Inconsistent suspend behavior

Discussion in 'Windows 7 Help and Support' started by nicocarbone, Jul 6, 2009.

  1. nicocarbone

    nicocarbone New Member

    Joined:
    Jul 6, 2009
    Messages:
    6
    Likes Received:
    2
    I am using Windows 7 RC x64 on a nForce 420 based motherboard. The suspend to ram function is not working properly sometimes.

    I have Windows configured to automatically suspend to PC after 30 min of being idle. This automatic suspend works well, suspending the PC completely, shouting down the fans, and leds of the PC, and can only be weaken up by pressing the on/off button in the case of the PC. After waking up from this state, I see that the temps of the GPU and the CPU are way down, proving that they were in sleep status.

    However, when I suspend manually (by pressing the suspend button on the keyboard, or by chossing suspend in the Start menu) the PC doesn't suspend completely. The fans and leds doesn't shout down, and the temp of the CPU and GPU after wake up are very close to the temps when idle, showing that they didn't enter in sleep state. When suspended manually, I can wake the PC just by touching any button of the mouse or keyboard.

    What is the problem? Is there a way I can manually completely suspend the PC? I checked on internet and in the forums an didn't found any solution to this problem.
     
  2. nicocarbone

    nicocarbone New Member

    Joined:
    Jul 6, 2009
    Messages:
    6
    Likes Received:
    2
    I found the solution to my problem. I had to disable "Allow this device to wake computer" on the keyboard, mouse and network card. Now the sleep function works perfectly. Thanks ronpeck from w7forums.com!
    Is there a way to mark this thread as solved?
     
  3. FountainDew

    FountainDew New Member

    Joined:
    Aug 22, 2009
    Messages:
    8
    Likes Received:
    0
    Hi, thanks for the info. Can you post the step-by-step on how you solved this problem? Thanks. :D
     
  4. nicocarbone

    nicocarbone New Member

    Joined:
    Jul 6, 2009
    Messages:
    6
    Likes Received:
    2
    Hi. You have to go to the Device Manager, and in every USB device that might be waking up your computer, double click on it, go to Power settings and disable Allow this device to wake up the computer. I have the Spanish version of Windows 7, so the names may be slightly different, but the idea should be the same. Hope this helps.
     
    FountainDew and (deleted member) like this.
  5. FountainDew

    FountainDew New Member

    Joined:
    Aug 22, 2009
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply! :D
     

Share This Page

Loading...