Incredibly slow file sharing, all other networking fine

Discussion in 'Windows 7 Networking' started by PCPete, Sep 1, 2010.

  1. PCPete

    PCPete New Member

    Joined:
    Dec 5, 2009
    Messages:
    14
    Likes Received:
    1
    This is a weird one...
    I have W7 x64 Ultimate on 10.10.10.2, connected via a switch to 10.10.10.1, my internet gateway running XP x32 SP3 (etc etc). Both machines are in the same workgroup, etc, and the private connection has NO firewalling at either end. I have uninstalled connection strangling (QOS crap) at both ends, and I'm using IPV4.

    I can connect to the gateway from W7 using RDP, it runs fine and flat-out fast, so the switch and cabling, etc, is fine, and all my internet access is full speed (1MB/s or faster depending on external connection speed, so the routing works fine).

    I can access and connect to shares at either end using machine names and shares (including from the command line, etc). However... When I connect to shares on either computer from the other computer (using machine/user/password or "classic" sharing) the maximum data transfer speed is less than 8kbps. So a large folder listing may take minutes to display, and copying an example 32MB document takes over 25 minutes.

    Obviously, I've tried the transfers with no RDP or any other connections active, and with or without RDP it's exactly the same.

    I've tried dozens of things, from changing to a home network, to creating profile rules to "allow all", I've recreated the shares, reconnected and disconnected literally hundreds of times, reset all firewall access and networking to defaults, and much more. Nothing changes - I get fast everything except share access.

    There are no errors or log entries in either machine's event logs. But I do notice that when I'm transferring, it looks like it sends/receives 32kbytes at a time.

    Can anyone help me figure out where the problem is? Hopefully not PEBKAC...
    AdvaTHANKSnce,
    PCPete
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Have you considered disabling IPv6 under TCP/IP connections for your Network Interface Cards in Windows? This can sometimes cause transmission problems on some routers, for whatever reason. Especially since you are showing us you have XP in the mix. I would try disabling IPv6 on all of the machines which have it active. By default, Windows 7 will try to communicate through the LAN using IPv6 most of the time, as has been my experience.
     
  3. PCPete

    PCPete New Member

    Joined:
    Dec 5, 2009
    Messages:
    14
    Likes Received:
    1
    G'day Mike,

    My bad, I forgot to mention that I've disabled IPV6 already on the W7 machine, and XP SP3 doesn't have any IPV6 drivers that I can see.

    So in my Properties page for the adapter on W7, I have checked :
    - Client for MS networks
    - File and Printer Sharing
    - IPV4
    - Link-layer topo discovery mapper i/o driver
    - LLTD responder

    I also have tried enabling and disabling Virtual Machine network services as I use VMs occasionally, but this makes no visible difference.

    N.B. I test each change by disconnecting from the share, then reconnecting and attempting a file transfer.

    Thanks!
     
  4. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    It sounds to me like the switch may be handling the netbios packets slowly for some reason - meaning I think the switch is somehow at fault.

    You could use Wireshark to sniff the packets on your machine to try to determine what kind of packets are hanging or being re-transmitted. If you tell us or do your own research on it, it may prove very helpful.

    Other than that, you could setup the machines to use the non-routable protocol called NetBEUI. It is more efficient and can not be hacked whatsoever from outside your internal network. This is what I use for local file and print sharing, with normal Netbios disabled.

    (Netbios shares are a cinch to hack.)

    Edit - Also make sure your adapters are set in device manager to be full duplex 100mbps or 1000mbps, depending on the switch and adapter types. (Try half duplex as a test if that doesn't help. - Latest drivers good to install too.)
     
    #4 TorrentG, Sep 1, 2010
    Last edited: Sep 1, 2010
  5. PCPete

    PCPete New Member

    Joined:
    Dec 5, 2009
    Messages:
    14
    Likes Received:
    1
    Cool, I hadn't thought of the switch being involved with the problem!

    But... I swapped switches with my dev hub (Hawking 5-port 10/100) and although the first few K copied much faster (24k/sec instead of 7), by 3 seconds in to the copy it had slowed down to 7.5k again. Sigh.

    Both adapters have been tried using full and half duplex, at 10MBPS (which makes my RDP and internet connections feel as slow as a modem) and 100.

    I think you're close to the money in terms of NetBIOS and NetBEUI... I've now tried manually enabling and disabling NetBIOS over TCP/IP at both ends, but that makes no detectable difference to the transfers (tried with both switches).

    I'm not concerned at all about hacking security on the internal network (that's the whole point of the gateway box), but I can't seem to find a NetBEUI install option from the adapter options page on W7 (XP shows the NetBEUI protocol is installable). Is it on the W7 install disk, or can I download it from somewhere obvious? I'd like to at least try the option and see if it makes a difference...

    Thanks for taking an interest in my strange little problem!
     
  6. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    If you've disabled Netbios in the adapter properties for IPv4, in Network and Sharing center (while clicking on local area connection) - that should have disabled all ability to transfer files across the network at all.

    What you can do as a simple test that isn't related to any of that, is to install an FTP server on one machine and use an FTP client on the other. (BPFTP and FlashFXP) Download something using this FTP protocol. If it works well or even if it does not, it can help you determine things.

    As for the NetBEUI, it completely slipped my mind that it will not work on 64 bit because the driver it uses (nbf.sys) is a 32 bit only driver. So this option is not valid for you.
     

Share This Page

Loading...