installing games and programs, getting internal errors.

Hey guys I've been having trouble installing some programs and games onto my windows 7 home premium edition, Upon trying to install the game "Just Cause 2" i put the disk in my CD drive and it pops up asking me what do i want to do? and it says run autorun.exe and it starts, but once it starts the setup to the game, i get an internal error, which reads as follows. "Internal Error: Failed to get path to 64-bit Common Files Directory." Now i checked my Program files(x86)/common files is there. I checked regular program files there was no common files directory there so i created a folder and went ahead and named it "Common Files" for the heck of it.. alas the same error still happens.. i've done some research on it and got to somewhere where Microsoft said to check my UAC-filevertulization in my registry, and checked the event I.D its "2001", if that helps.. anyways.. any thoughts or am i screwed? lol

can anyone help me with this?!

Did you contact support ?

1. Disable UAC
2. Rigt-cick autorun.exe/setup.exe -> Compatibility -> Run as an administrator

i think i disabled UAC, went to it. hit disable log?..also tried run as admin, that did nothing. i'm not sure how to contact support, as i bought windows 7 off neweggs its OEM's system builders kit.

thanks for the reply, much appreciated.

also tried the Registry booster as advertised on the site.. same error applies.. i got to selecting "English" in the setup, immediately after that the error happens.. like i said above..

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.