Installing IIS7?

Discussion in 'Windows 7 Help and Support' started by StarPilot, Mar 16, 2009.

  1. StarPilot

    StarPilot New Member

    Joined:
    Mar 16, 2009
    Messages:
    4
    Likes Received:
    0
    I've gone throught he control panel and optd to turn *everything* on under IIS and it still will not serve any pages. When I run ASPNET_REGIIS -i it turns out this error:

    C:\> C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i
    The error indicates that IIS is not installed on the machine. Please install IIS
    before using this tool.
    Finished installing ASP.NET (2.0.50727).

    Does anyone have any tips/tricks on getting IIS7 running correctly? Do I need to reinstall the .NET framework?

    Help please!
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I'm no expert on this, but try the following.........

    I can't remember what Control panel item I located this in, but go to Start > Run, and type optionalfeatures and hit Enter.

    Scroll down until you see Web Management Tools and expand that tree. Problem is it only reveals II6, not II7. Look through all the various sections such as World Wide Web Services, Security. .NET Framework and possible Windows Product Activation Services.

    I believe Windows 7 comes with .NET Framework 3.5 already installed by default.

    You can check your version by going to c:\windows\Microsoft .NET.
     
  3. StarPilot

    StarPilot New Member

    Joined:
    Mar 16, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks. I was already headed down that path. It took me uninstalling the framework (2.0-3.5 sp1) and reinstalling them *after* I found all the IIS doo-dads. Several reboots & installs later it is up and running. <phew/>

    I've been tackling this for nearly 7 hours straight now. Glad it is up and running.
     

Share This Page

Loading...