Installing W7 on SSD (GPT)

#1
So I try to install Windows 7 onto my SSD for a completely new comp - and in the 'where do you want to install windows' window I have 2 partitions.

Disk 0 Partition 1 - 100MB total size, 86MB free space, System - type - 'Windows cannot be installed to this disk. The selected disk is of the GPT partition style. Windows cannot be installed to this hard disk space. The partition is an EFI system partition (ESP)'.

Any advice?
 


#2
Can you post some screen shots of your disk management window?

Note: that partition of 100mb is something that windows uses, it's the active boot partition. You will need to install it on the next available space on the C drive. Which that 100mb partition is apart of. So format C and install on C, it will create that 100 mb partition every time.

What is the 100MB System Partition used for ?

Can I delete the system reserved partition from 100MB - Microsoft Community
 


#3
The motherboard being used is GA z77 d3h


 


#4
Yep...that's how it should look because you only have one drive...you need to install it on the unallocated space of the drive.

Pay no attention to the 100 mb partition...just pretend it's not there.

Just click on the unallocated partition, format it if you want to, and install the OS.
 


Last edited:
#5
In the last screenshot you can see what happens when I click on the unallocated partition - it says'Windows cannot be installed to this disk. The selected disk is of the GPT partition style'.

Unfortunately that photo doesn't show that the 'delete', 'extend' and 'format' buttons are greyed out aswell as the 'next' button.

The only buttons I can press for that '119.1GB' partition are 'refresh', 'load driver' and 'new'.


Sad days

Edit: didn't realise it shows the next button greyed out :O
 


Last edited:
#7
That thread is quite in depth. I wouldn't mind going through it if it's relevant.

Does that thread contain the solution to how I can install windows 7 on this OCZ vector SSD, which is what I'm trying to do. ?

I'm asking you if it's relevant because I don't know - 'dynamic disk' doesn't mean anything to me right now - but if you are confident that thread has the answer to my problem, I'll learn what's in it.
 


#8
It looks like there was an option to select from basic to dynamic in the initial setup that was selected.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#9
In order to install Windows on a GPT configured drive, you have to boot to the UEFI version of the Install Media. You do that by selecting it in a Boot Device type menu when the system boots.
 


#10
Yes the issue seemed to be solved but it looks like a lot of extra effort after that option to select the dynamic disk was checked/ticked. But in the end it was solved and poster was able to boot up system into windows 8.

Good luck.
 


#11
In order to install Windows on a GPT configured drive, you have to boot to the UEFI version of the Install Media. You do that by selecting it in a Boot Device type menu when the system boots.
The motherboard is in the UEFI version.

It boots, I press F12 and get 'UEFI : ATAPI iHAS124 D

Does the SSD have to be UEFI aswell? - if so, that would seriously confuse me, it being a storage device afterall

EDIT: additionally, I never selected anything resembling 'dynamic disk'. All I have clicked on is 'install' and the buttons you see in the previous screenshots.. that would be annoying to have to do all that T_T



I believe I also pressed a random key, and then enter for system start aswell and then set english as the language
 


Last edited:
#12
Strange, I restarted - and now instead of the popup talking about GPT (for the NON sytem partition) - I just have an error coming up.

Windows is unable to install to the selected location. Error:0x8007045d
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#13
How did the EFI system partition get on the drive? Was that done during the install? It should not have an EFI partition without the OS partition to go with it. Maybe just removing the EFI partition and starting over would fix the problem.

Edit: Also, the fact your screenshots do not show an MSR partition is not normal.

When you select the drive during the install, you originally selected the entire drive's unallocated space?

Where did you get your install media? I would not expect to see a GPT message unless the install was using MBR.

What model is your SSD, I remember seeing one thread with someone having a problem with one. Maybe a firmware update could be needed.

If all else fails, use Shift+F10 to open a command prompt. Diskpart would also tell you if the drive was Dynamic, which it should not be. Type Diskpart to start the utility, then:

lis dis

to see what drives are available and if it is noted as Dyn. If you do not want to clean the drive, just exit here.

sel dis 0

if the drive you want shows as 0

clean

This will wipe the drive

exit
exit


Then refresh the view or reboot and try again.
 


Last edited:
#14
That worked! Saltgras you are a lifesaver - if I could hug you I would :D I guess you're just going to have to live with the fact you made my day super awesome and :) <-- smiley face

Also thankyou bassfisher for linking me that article - I will look over it in more detail at somepoint because right now I feel really stupid considering how much there is to know about computers and how little I know as of yet :S *inb4 you think "yes, yes you are"

xD
 


#15
Glad you got it fixed....

Nice job Saltgrass
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top