Internal Mouse Problem

#1
Hi -

I have a Lenovo T410 thinkpad running Windows 7 64-bit, and yesterday I spilled a bit of syrup on the trackpad and the left and right buttons that sit directly below it. It wasn't much, and I tried to wipe it up immediately. Afterwards, the interal mouse has gone in and out of functionality. I can still use the swipe/scollpad to move around the cursor without trouble, but I cannot click/select anything. When the mouse cursor hovers over an item, it will not even highlight the item or change form itself (e.g. from an arrow to a hand over a link), which makes me think something is messed up beyond the buttons themselves (which I plucked up and tried to clean).

I plugged in a wired mouse, and for the first several minutes it still did not work but eventaully it recognized it and with no trouble, but when I restart with no wired mouse, back to square one.

Appreciate any thoughts/help.

Thanks.
 


Digerati

Fantastic Member
Microsoft MVP
#2
Hmmm, the solution seems obvious to me - the keyboard assembly needs to be disassembled and professionally cleaned. This is not really a difficult task, technically, but it can be time consuming and a bit tedious.

The problem is not likely to get better over time as the sticky syrup will start to collect dust, dirt and buttery pancake crumbs. ;) So from here, it seems you need to take it to a shop for professional cleaning, or live with an external mouse and hope all the keys continue to work properly.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top