Internet Connection Problems

#1
Hi, i have some problems conencting to my website, my website is on this pc(apsperver). When i try to connect to it with local ip (127.0.01) it works, but when i use my global ip, it wont work. When i press diagnose connection problems i get this error :
[TABLE="class: info"]
[TR]
[TD][TABLE="class: info"]
[TR]
[TD="width: 20"][/TD]
[TD="class: title"]website (213.180.109.186) is online but isn't responding to connection attempts.[/TD]
[TD]
[/TD]
[TD][/TD]
[/TR]
[/TABLE]
[/TD]
[/TR]
[TR]
[TD="class: content"]The remote computer isn’t responding to connections on port 80, possibly due to firewall or security policy settings, or because it might be temporarily unavailable. Windows couldn’t find any problems with the firewall on your computer.


[/TD]
[/TR]
[TR]
[TD="class: content"][TABLE="class: info"]
[TR]
[TD="class: title"][TABLE="class: info"]
[TR]
[TD="class: title"]Contact the service provider or owner of the remote system for further assistance, or try again later[/TD]
[TD="width: 110"]Completed
[/TD]
[/TR]
[/TABLE]
[/TD]
[/TR]
[/TABLE]

I have no firewall, AV, i have re-installed windows like 500 times, i have rebooted EVERYTHING like 100 times, i used DrTCP to set UMT, still nothing. I have spent like 4days in google.

MyPC -> Rooter -> Hole in the wall -> Modem

What should i do ?[/TD]
[/TR]
[/TABLE]
[TABLE="class: info"]
[TR]
[TD="class: heading"]
[/TD]
[TD="align: right"]
[/TD]
[/TR]
[/TABLE]
 


Captain Jack

Extraordinary Member
#2
Hello there!

Is Port 80 open in your Router? Go to Open Port Check Tool and there test Port 80 and see if it's open.
 


Trouble

Noob Whisperer
#3
When I hit your server using a browser, I get the page in the attached image. Is this what you are thinking it should look like? If so your router appears to be forwarding port 80 OK, unless of course it's not even behind the same network address translation router as the machine you are trying to hit it from.
Can you explain your network to us in so far as the location of the machine you are using for development and the machine that is actually hosting the site. Are they one and the same? Are they on the same subnet?
 


Trouble

Noob Whisperer
#4
Sorry, if I would have read your OP more closely I would have realized that since your problem states that you can access the website using the localhost loopback address (127.0.0.1) that you were developing and hosting on the same machine. So it's important to note that most routers will balk at going out and coming back in to locally hosted services, it's kinda of the whole idea as to how NAT works, you use local addresses for locally hosted services on your same subnet.
I think the actual problem has something to do with the send and destination address for packet requests being the same (the outside edge address of the router) so when your looking for a webserver with the same address as the outside address of the router it request hits the outside edge and doesn't have anywhere to go as the source and destination is the same.
The next hop, upsteam router would probably answer if at all, with something like, what are you asking me for, you already know the answer to that, it's you. So it doesn't ever really obtain a route path resolution since it's already at where it's going, if that makes any sense at all.
 


#5
Hi, thanks for your replays i have fixed it.
The problem was that in my router i fowarded ports to http://192.168.1.100/ , but i needed to foward them to http://192.168.1.101/ , i didn't know that becouse it worked earlyer with that ip, idk what did chage but now it works only with ip (.101), i hope that this will help someone .
 


Trouble

Noob Whisperer
#6
Yes, that looks a lot better. Glad to hear that you were able to resolve your issue and thanks for posting back and updating your thread with your solution.
You might want to check and confirm that you are not using DHCP on that NIC interface as that will likely result in the problem reocurring again at some point. It's better to manually assign a static value so you won't have to keep adjusting your port forwarding entry on your router.
Hope to continue to see you around the forums.
Regards
Randy
 


#7
Thanks.
I have 2pcs at home. One connected with router other with wireless so when i disable DHCP my wireless pc gets an ip error like "cannot recive ip address" "no ip adress", why so ?
 


Trouble

Noob Whisperer
#8
You don't need to disable DHCP on your wireless router. I was suggesting only that you assign a static value for the network adapter you are using on the webserver. Just determine what the scope of IP addresses is that it is handing out and either create an exclusion for a specific address or restrict the scope and then use an IP address that it is not handing out (outside the scope range) some routers will also support a feature that's called a "Reservation" so you can reserve the same IP for the same machine everytime and that might also prevent your's from changing on your development machine.
So....
Reservation
Exclusion
or pick an address outside the DHCP scope.
Typically a standard Class C private reserved address range like
192.168.1.0 through 192.168.1.255 with a subnet mask of 255.255.255.0
supports a total of 254 hosts 192.168.1.1 through 192.168.1.254
looks like your router is handing out IPs starting at 192.168.1.100 (check the router interface to confirm), so anything lower like 192.168.1.69 should be fine and outside the range. However, some routers DHCP the entire range so check your's to be sure.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.