Internet connection sharing not working

#1
My goal is to use a cable internet connection and share it via wi-fi to my phone. Trouble is my phone doesn't see the wi-fi network I created.

I am aware that there are a lot of tutorials on how to do this and a lot of troubleshooting tips around. I have tried everything I could find but no luck so far.

What I have done so far:
Enabled sharing on cable connection's adapter.
Crated ad hoc network and connected the wi-fi adapter to it.
Made sure IP addresses are automatic.
Temporarily turned off firewall.
Temporarily turned off user account control.
Made sure all relevant services are running.
Restarted the adapters.
Restarted the computer.
Let Windows look for problems with the adapters.

The main idea for having the screenshot is the red X on the wireless connection. It sais it's not connected even after it is connected to the ad hoc network. I haven't worked out if that is OK or not.
network.png

Hope you can help.
 


#2
So finally it works.

What I did was enable Microsoft Virtual WiFi Miniport Adapter (Wireless Network Connection 2). I shared my cable connection to it.
And then from command line:
netsh wlan set hostednetwork mode=allow ssid=VirtualNetworkName key=Password
netsh wlan start hostednetwork
(replaced the VirtualNetworkName and Password of course)

It's not the ad hoc network I originally wanted. It's better.

Note I did install a hotfix to make it work since the start command resulted in an error at first. Also an hour or two of googleing was needed.
 


Last edited:

zvit

Honorable Member
#3
It's great when users post the solutions to their own issues. It's a great benefit for others who have similar issues. Thanks for that!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.