internet explorer 9

Discussion in 'Windows 7 Help and Support' started by loafty, Aug 15, 2011.

  1. loafty

    loafty Senior Member

    Joined:
    Oct 9, 2010
    Messages:
    41
    Likes Received:
    0
    the issue is when trying to use the BACK button to return to the previous page. It seems that on numerous occasions that upon hitting the back button, it will return to the previous page momentarily and then go back to the page I was very first on at start on and I have no idea how to fix this problem so am hoping someone will be able to help me please
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,796
    Likes Received:
    1,563
  3. loafty

    loafty Senior Member

    Joined:
    Oct 9, 2010
    Messages:
    41
    Likes Received:
    0
    yes I have run ccleaner and it hasn't helped,Thanks
     
  4. Kultz

    Kultz New Member

    Joined:
    Aug 12, 2011
    Messages:
    30
    Likes Received:
    0
    Try to change IE9 settings or something like that.
     
  5. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,796
    Likes Received:
    1,563
    You could try re-installing IE9. Open the control panel and navigate to Programs: Turn Windows features on or off. Uncheck IE9 and then reboot.
    To install just reverse the process. If this still fails to help perhaps you could provide a link to a web page where this issue appears.
     
  6. loafty

    loafty Senior Member

    Joined:
    Oct 9, 2010
    Messages:
    41
    Likes Received:
    0
    I have tried un and re installing it and that doesn't fix it either, GOOGLE still giving me trouble BUT if I go to IGOOGLE it seems to work properly so it has me beat
     
  7. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,046
    Likes Received:
    300
    Hi

    I've run into that problem too, but with Google Chrome. Often I click and nothing happens or it goes clear back to the first page.
    I've discovered that this happens if I click on the back button on the screen but not if use the back (side) button on my mouse.

    I don't know if that's any help, but it you have a 5 button mouse give it a try.

    Mike
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I always assumed some of that behavior is due to the web site. Have you tried right clicking the back button to see if there is a list you can use to go back to? Sometimes I have had to go to an earlier page to get away.
     
  9. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Couldn't agree more with Salts here, often times websites will redirect if something on the site has changed since it was last indexed on Google, or sometimes because the web admins of that specific site are just incompetent people. This happens frequently in Chrome to me as well, I click back and it either redirects me or does nothing, I hit the back button again and it takes me back two pages.

    My thoughts are that if the behaviour is very consistent, you should check to see what addons you have running within Internet Explorer. Disabling/uninstall un-needed ones also has it's (browser) performance benefits.
     
  10. loafty

    loafty Senior Member

    Joined:
    Oct 9, 2010
    Messages:
    41
    Likes Received:
    0
    Thanks all who have replied, I have tried everything that was suggested but nothing has fixed this issue
     

Share This Page

Loading...