Internet only, No Local Network

Discussion in 'Windows 7 Networking' started by kqmaverick, Jun 30, 2009.

  1. kqmaverick

    kqmaverick New Member

    Joined:
    Jun 30, 2009
    Messages:
    4
    Likes Received:
    0
    I recently purchased a new PC and decided to load it with the Windows 7 x64 RC. My only issue currently is that the PC isnt joining my Home Network Properly. If i open the Network Status i see my connection listed as Internet Only and not Local and Internet (screenshot below). Because of this when i try to access network shares VIA their name as in \\storage i receive an error (screenshot below), and Network shares are not listed in the Network Area of my computer. I can still access my network shares fine VIA their Static IP though. Ive already removed myself from the default windows Homegroup and ive insured that the Workgroup names all match. Any ideas on what could be causing this?

    [​IMG]

    [​IMG]
     
  2. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    I'm getting exactly the same problem. I can get full access to the Internet which is great, but I'm only getting limited access to my local network which is a full Windows 2003 Domain. This has only happened since I unjoined and rejoined my laptop to the Windows domain.
     
  3. ickymay

    ickymay New Member

    Joined:
    Jan 12, 2009
    Messages:
    1,689
    Likes Received:
    113
    have you made sure the Homegroup has full permissions on the computer you are trying to access ?

    also do not use the Homegroup link to access the remote pc but use the network link ?
     
  4. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    How do you grant the Homegroup permissions? Do Homegroups exist on Windows 2003?
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    No, Homegroup is only a Windows 7 feature. If you'd like to share with a Windows 2003 machine, you'll need to setup classic sharing (as it has always been before the introduction of Windows 7.)
     
  6. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    I thought as much. I'm really confused by what's happened here because before I took my laptop off the Windows 2003 domain and re-added it, it had Local Network and Internet access. Is there something I need to configure on Windows 7 in order to make it trust the W2K3 server? I can ping it, and access the DC remotely using VNC, but that's it.
     
  7. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Control Panel (while viewing Large Icons.)>>>

    Network and Sharing Center

    Top left, click on Change advanced sharing settings. Click the dropdown arrow for the type of network you chose to use, previously.

    Make sure these settings are applied:

    Turn on file and printer sharing.

    Use 128-bit encryption to help protect file sharing connections

    Turn on password protected sharing

    ----

    Then on the machine you want to share from, make sure the folders needed to be accessed are shared with permissions for "Everyone" without the quotes. (If you need help with this, please let us know. You actually have to type Everyone and then grant the type of access you want to give.)


    ----


    Then make sure the accounts involved on all machines actually have a password set. It is easiest if all machines involved have the same user/password set but surely not the only way.

    What you DO NOT want to do is have the same user on 2 different machines that have DIFFERENT passwords.

    If you are sharing between different user names, while mapping a drive, you can set it to use different credentials and also remember them upon all Windows reboots.

    Anything else needed, please let us know and good luck.
     
    #7 TorrentG, Jul 3, 2010
    Last edited: Jul 3, 2010
  8. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    I'm still having the same problem. I've noticed that my domain has been identified by Windows 7 as being a domain network as opposed to a Public or Home network. Either way, I can browse the admin share on the discs on my domain controller but if I try to map a drive to anything other than a $ share, it tells me access is denied. I could understand that if it wasn't for the fact that I haven't tinkered with the access permissions on the folder I'm trying to map to for ages.
     
  9. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Physically go to the machine you want to share from. Open My Computer (a.k.a. Windows Explorer). Top left, click Organize then Folder and Search Options. Click view tab. Scroll to bottom and remove the check next to "Use Sharing Wizard (Recommended)" and hit ok. (It will be slightly different on Windows 2003 but you should be able to find it. Perhaps it is on the right under view or something, I forget now.)

    ----------

    Now, right click on the folder you'd like to share (the one to be mapped from Windows 7.)

    Choose properties, then sharing tab. Click advanced sharing. Check the box to share this folder. Click add. Type in a share name then click permissions.
    Click add, then type "Everyone" without the quotes. Hit ok.

    Check the boxes for Full Control or Change permissions if you'd like to give that level of access.

    Hit ok until all the property boxes are closed. Test mapping the share from the Windows 7 machine now.
     
  10. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    Ok, so I have a partial success: the suggestion has worked insofar as I can now map the drive. The problem is that Windows 7 is still only connecting to my wireless router for Internet Access only which means that the laptop isn't getting the correct user account information from the Domain Controller. I'm a member of the Domain Admins group on the network, but still can't perform various tasks on the laptop because I don't have sufficient user rights.
     
  11. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Are you sure you have a Domain instead of a Workgroup? Only reason I ask is because almost every home network uses Workgroups and Domains are generally for office/corporate use. Of course there are exceptions and this is probably one of them but still had to ask heh heh.

    If no real domain, you could make sure that all pcs are on the same Workgroup. In Windows 7, you can hit the Windows key + Pause key at the same time to open the screen to set the Workgroup name. On this screen, all you need to do is click Change settings.

    Of course, if you really are on a domain, then this advice doesn't apply. Perhaps the domain controller itself is denying certain types of access. If you are able to map drives, then it definitely is not an issue of local lan access, network speaking.
     
  12. ianbhenderson73

    ianbhenderson73 New Member

    Joined:
    Jul 2, 2010
    Messages:
    12
    Likes Received:
    0
    I'm definitely on a Domain rather than a Workgroup. I'm running Windows 2003 Standard server. Prior to disjoining the laptop from the network I had the right accesses to the network - it's only since the laptop was joined back onto the domain that the problems have started. I know I've changed nothing on the server however.
     

Share This Page

Loading...