Internet stops woking for no apparent reason...

#1
Windows Vista Business Edition. I've been having lots of problems with it regarding internet.

I've got access to a wired and a wireless network at home. I also have a localhost server on my computer which I access through localhost (127.0.0.1). Now, sometimes I'm using the internet and it stops working for no reason. It can happen while using the wired or wireless network, it doesn't matter. It just stops working.

Fun facts:
  • If something like a file download or a MSN Messenger session is on while the problem occurs, the file and/or msn session still work (though slower and/or with major problems).
  • If I'm using the wired connection when it gets screwed up and then try to get wireless connection, it still doesn't work.
  • I have no access to my localhost (404'd).
  • Of course, all browsers and network-capable applications stop working when this happens.
Rebooting solves the problem, but it's annoying as hell.

While I'm at it, I might add that I have avast free home edition antivirus, I installed xampp to get php, MySQL and Apache and Windows firewall turned off (those are the programms I have that I think may be causing a problem).
 


#2
Easing out net connections

You havent mentioned processor speed and RAM..if its not adequate..plz add it..at least one GB RAM..then remove all those unwanted programmes including virus scanners...and use deep freeze instead...delete all temp internet files....i think this much will solve ur problem.
Ranjith
 


U

Unregistered

Guest
#3
I feel like it might have to do with the Avast software as I experience the same problems and I use Avast as well
 


#4
hi.. am new here.. but I have a similar problem...
My connection stops workin but i have narrowed down to a copuple of things...

I've noticed that it only happens when I open any p2p software (my case utorrent and Ares) once i start those, they work well... but i cant do anything else... no browsing no nothing... i cant eve ping my router when these programs are open and the only way to solve it is by restartin vista... it only happens after i open any of these programs...

In fact the only thing that stays open is the live messenger.. but only if I start it before startin p2p... after that, it still works... I know that its not a hardware issue because it never happened on XP and am using the same pc, now with vista...

Any thoughts???? thanks in advance...
 


Celestra

Former Moderator
#5
Re: Internet stops working for no apparent reason...

Hi! What kind of error codes do you get when this happens? I thought suddenly of "Win Sock Corruption", but I would need to know what error codes you get.... There's a fix for it if that is what it turns out to be.
 


#6
hi...
well in my case.. i dont get any error codes or error messages.... any connection after starting p2p just stops... and even if i close p2p... connection stays dead... i cant even ping localhost... :S
 


Celestra

Former Moderator
#7
Re: Internet stops working for no apparent reason...

Happy Holidays Everybody!!! First off, I would like to leave this article for people to inspect. Win sock corruption is the result of UN-installing- installing programs that relay heavily on the Win sock. A big offender would be your security programs. So, take a look, they've included a huge data base for assistance. WinSock Fix Techniques - Recover from Network Corruption in Windows XP and Vista :) (Colo1) I'll look into this further, and see if I can't offer other suggestions.....
 


Celestra

Former Moderator
#8
hi...
well in my case.. i dont get any error codes or error messages.... any connection after starting p2p just stops... and even if i close p2p... connection stays dead... i cant even ping localhost... :S
Modems/Routers that are known to have problems with P2P Apps (From Azureus, but applies to UTorrent too.. The "Bad News Moderator" has a few links you might want to check out: forum.utorrent.com / Internet disconnects when using uTorrent
 


#9
thanks, I'll check it out... hope I find something there.. thanks again... I'll let you know if it works ;)
 


Celestra

Former Moderator
#10
thanks, I'll check it out... hope I find something there.. thanks again... I'll let you know if it works ;)
maybe take NOD 32 off...
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.