Internet works but not browsers

#1
I'm using Windows 7 Home Premium 64-bit.

Lately when I try connecting with any browser it says I can't like the internet is unplugged. But I can download and install Windows 7 updates. I was maybe thinking it was a virus so I installed Malwarebytes and Superantispyware. Malwarebytes wouldn't update but SAS would. It had AVG anti-virus 2011 and I uninstalled it with the Windows built in uninstaller. Then I tried using "avg remover 64 bit" and I got the message "the version of this file is not compatible with the version of windows you are running" which is strange because I have the 64 bit version of Windows. I got suspicious and tried running TDSSKiller.exe, rkill.com and some other AV programs but got the same "the version...". I read in a couple of searches that it's probably a virus and since I can't run any AV stand alone program, I suspect it is. When I ran Malwarebytes and SAS, it showed no virus's which I don't believe. Also everything in the Network and Sharing Center is totally normal showing that all is working fine. So if I can't run any of my anti-trojan, etc. programs, I can't see what it might be. This does the same in Safe Mode.
 


Elmer

Extraordinary Member
#2
Hi raiden

Download the correct Microsoft Standalone System Sweeper for your system.

Burn to disc / usb stick. Make sure the DVD drive / usb drive is set to boot first in the bios, re-start and run the system sweeper.
 


#3
Ran the sweeper but no change.
 


Elmer

Extraordinary Member
#4
Just a thought. Did you run the many programs in Safe Mode?
 


#5
Yes, I ran them all in safe mode and regular mode.
 


Elmer

Extraordinary Member
#6
I have this habit of stopping reading two sentences from the end!! :)
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#7
Hi

Go to your Lan settings and make sure that is is set to Automatically Select Settings.

In Google Chrome I get to this by going to Options, Under the Hood, Network, Change Proxy Settings.

Many malware programs will change this setting to a proxy server witch lets the internet work but keeps you from connecting to anything.
This can persist even after the malware is removed.

I'm surprised that you didn't find any malware with Malwarebytes.
This sounds exactly like a malware problem.

Mike
 


Last edited:

davehc

Essential Member
Premium Supporter
#8
I have just this moment been made aware of this attack. Very valuable and interesting. Perhaps it should be pinned.
It occurred to me you could be suffering? You symproms are not entirely the same, but, ??
Check if rogue DNSChanger has changed your DNS settings | The Windows Club
 


#9
Sorry for the delay, but I realized this problem has only been here for a week. So I did a system restore (in normal moded) to about 2 weeks ago but the restore got hung up for too long (something about the registry) so I restarted and ran the fix start option. So I guess the restore didn't work and I'm still where I was at the other days.

Here are some notes:

-running Win 7 Home Premium 64-bit
-Only 64 bit IE9 works
-trying to run AV programs like TDSSkiller and rkill.com give a message saying file is not compatible with the version of Win 7 i'm running, unless I need the 64bit versions which I've never needed before
-everything seems normal connection wise (wired and wireless), but Chrome says in options that it is using a proxy to connect, but when I go to change it, it is not set to proxy, just the normal settings
-seems like a sneaky virus, but is it?
-I've run all the anti-virus programs I can, including all the ones mentioned
-malwarebytes won't update but SAS will
 


Elmer

Extraordinary Member
#10
Try the system restore in Safe Mode, although it's un-reversable (???). Any restores that have failed for me in normal mode have never failed in safe mode. Make sure to grab a copy of the affected programs list.
 


Trouble

Noob Whisperer
#11
Click the start orb and type
inetcpl.cpl
and hit enter
select the Connections tab
and click the LAN settings button
Uncheck all the check box and click OK and OK
See if you can launch IE9 and open a web page
If not type this into the Address /URL bar of your IE9 and hit enter
209.85.145.105
Let us know the results
 


#12
I tried sys restore in safe mode but it failed. I also tried all of the above and no change at all.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#13
Maybe we should back up a little.

What is your network configuration? Is computer wired to router which goes to modem?

If you have a router can you access its admin page using its IP address?

If you open the Network and Sharing window, do you see a red x anywhere? Any other messages and do you show as a private network (house)?

Only 64 bit programs are able to run? If you can, open an administrative command prompt and type SFC /scannow to check your system files. {Winkey and type cmd then CTRL+Shift+Enter}

Any Error messages in the Event Viewer?
 


Last edited:
#14
My connection is modem to wireless router. It doesn't matter about how I'm connected because I have tried 3 different houses with totally different connections. I can't access my router using it's IP. And there are no X's anywhere and it is private. When I try scannow a command window opens for half a second then closes every time I try it.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#15
You are running the scannow command in an Administrative command prompt? The command prompt window should not close, but only give some type of message, unless it might be another symptom of your problem.

If you are using the command prompt window, open Task Manager and see if TrustedInstaller is listed on the Services Tab.

If it is, open Services.msc and see if you can start and stop the "Windows Module Installer"? It will probably be not running so don't worry unless you cannot get it to start. The fact you can do Windows updates might rule this out, but won't hurt to check.

If a virus has caused the problem, unless you can somehow identify it there may not be a way to recover without at least a Repair Install. Were you able to boot to a copy of the Microsoft Bootable Anti-virus Elmer suggested?

I have been trying to think of some service that might not be running and causing a problem, but I do not know of one, so I was hoping the File Scan might replace some bad system files.

Otherwise, the things that might be blocking just the Browsers might be an anti-virus, or a firewall, or a previously mentioned virus..
 


#16
I ran the scannow in an administrative command box and it said everything is good. I tried the bootable MS anti-virus but it found nothing.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#17
Also try running Malwarebytes in safe mode.
The fact that it won't update also sounds like malware of some sort.

You can also try changing the name of the Malwarebytes .exe file to anything else, just don't change the extension.
Some malware has a list of malware programs and actively blocks updates etc.
I've found this in the ones that give you the pop ups saying you have a virus.

As weird as it sounds changing the name of the .exe file can fool the malware into not recognizing what you are running, and allow it to run normally.

I've found Malwarebytes to be the most effective software for getting rid of these things, but it will have to be up to date.

Mike
 


Trouble

Noob Whisperer
#18
I tried the bootable MS anti-virus but it found nothing.
When you booted to the MS system sweeper disk, did you select full system scan? I believes it defaults to "Quick" additionally I believe you can also customized the scan to also include drives / partitions other than you system drive. You may want to try that as well.
 


#19
OK, I tried Malwarebytes in safe mode and I renamed the .exe and ran it. It still didn't find anything. And your right, it usually always finds something. And as for the MS boot AV, I did select full scan when I ran it.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top