iPod Touch connects but won't charge

Discussion in 'Windows 7 Help and Support' started by KevinJ90825, Aug 20, 2009.

  1. KevinJ90825

    KevinJ90825 New Member

    Aug 20, 2009
    Likes Received:
    My 2nd generation iPod touch will connect to the computer and shows up in iTunes I'm able to play music off of it and sync music to and from it. The problem however is that it won't charge. On the ipod, the icon in the upper right which shows the battery is just rapidly switching from the charging icon to the plugged in icon. I had it plugged into the computer all of last night and the battery is at the same level as it was before. This worked fine on Windows XP so I'm thinking it has something to do with Windows 7 being installed. Any suggestions on what might be happening? Thanks!

    Edit: By the way, I just checked and the iPod charges fine in another computer with Windows XP installed on it.
    #1 KevinJ90825, Aug 20, 2009
    Last edited: Aug 20, 2009
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Aug 28, 2007
    Likes Received:
    Have you tried using a different USB port?

Share This Page