IRQL_NOT_LESS_OR_EQUAL (please help).

#1
View attachment BSOD.zip View attachment BSOD.zip

Quick explanation. My SSD broke, RMA'd it, got my replacement, installed Windows 7, all necessary drivers and software. All was well. Then I accidentlymisplaced some important folders etc. easiest solution was to reinstall Windows which I did. Now every time I try to install drivers for my graphics card I get the IRQL_NOT_LESS_OR_EQUAL BSOD.

If the attachment worked properly, all the info should be attached.

So far, I've tried Memtest, but the RAM is fine. Using a different version of the drivers, but I get the same BSOD upon restart anyway. And I'm out of ideas right now. Although I'm amost certain it has something to do with my GPU or it's drivers.

Would really appreciate any help on this. Thanks!

EDIT: This is incase the attachment didn't work correctly.

https://rapidshare.com/files/2497435143/Windows_NT6_BSOD_jcgriff2.zip
 


Last edited:

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#2
Hi,

Do you have any .dmp files for us to look at. Pics of CPU-Z every tab would be useful too :) If your .dmp file is too big for the site could you upload it to rapidshare :)
 


Last edited:

Trouble

Noob Whisperer
#4
Yes that helps some. A couple more might be helpful.
There is a bit of initial confusion your dump file reflects an issue with
igkmd64.sys which I believe is an Intel based Graphics chipset, but your system specs show an Nvidia GTX 580.
Is it possible that you have an integrated / embedded video card on your ASRock motherboard, and is there a way, if you are using an add-on card to disable the integrated card in your System BIOS?
DUMP FILE:
Code:
...
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck A, {fffffa7fffffffe0, 2, 1, fffff8000d1b119c}

Unable to load image igdkmd64.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for igdkmd64.sys
*** ERROR: Module load completed but symbols could not be loaded for igdkmd64.sys
Probably caused by : igdkmd64.sys ( igdkmd64+8d84f )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: fffffa7fffffffe0, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff8000d1b119c, address which referenced memory

Debugging Details:
------------------


WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff8000d2f40e0
 fffffa7fffffffe0 

CURRENT_IRQL:  2

FAULTING_IP: 
nt!MiAllocateMostlyContiguous+85c
fffff800`0d1b119c f00fba6b1000    lock bts dword ptr [rbx+10h],0

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0xA

PROCESS_NAME:  csrss.exe

TRAP_FRAME:  fffff88005b3b060 -- (.trap 0xfffff88005b3b060)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
rdx=ffffffffffd0d000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff8000d1b119c rsp=fffff88005b3b1f0 rbp=fffff88005b3b240
 r8=0000000000000000  r9=0000000000000003 r10=fffff8000d249440
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
nt!MiAllocateMostlyContiguous+0x85c:
fffff800`0d1b119c f00fba6b1000    lock bts dword ptr [rbx+10h],0 ds:2b60:00000000`00000010=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000d0bbb29 to fffff8000d0bc5c0

STACK_TEXT:  
fffff880`05b3af18 fffff800`0d0bbb29 : 00000000`0000000a fffffa7f`ffffffe0 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`05b3af20 fffff800`0d0ba7a0 : fffffa80`0b2c2b00 fffffa7f`ffffffd0 00000000`00000000 fffff880`05b3b090 : nt!KiBugCheckDispatch+0x69
fffff880`05b3b060 fffff800`0d1b119c : fffffa80`06cacb30 fffffa80`00000000 fffffa80`0b2c2b60 fffff800`0d3cf294 : nt!KiPageFault+0x260
fffff880`05b3b1f0 fffff800`0d1def5e : fffffa80`0b6fb7d0 00000000`00000100 00000000`00000000 00000000`000000ff : nt!MiAllocateMostlyContiguous+0x85c
fffff880`05b3b340 fffff800`0d1df5e9 : 00000000`00000000 fffffa80`0b6fa000 fffffa80`0a24c760 fffff880`0486ee85 : nt!MiAllocatePagesForMdl+0x62e
fffff880`05b3b440 fffff880`048bb84f : 00000000`00000000 fffffa80`0a24c764 00000000`00000001 00000000`00001598 : nt!MmAllocatePagesForMdlEx+0x89
fffff880`05b3b480 00000000`00000000 : fffffa80`0a24c764 00000000`00000001 00000000`00001598 00000000`00000000 : igdkmd64+0x8d84f


STACK_COMMAND:  kb

FOLLOWUP_IP: 
igdkmd64+8d84f
fffff880`048bb84f ??              ???

SYMBOL_STACK_INDEX:  6

SYMBOL_NAME:  igdkmd64+8d84f

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: igdkmd64

IMAGE_NAME:  igdkmd64.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4e5e9129

FAILURE_BUCKET_ID:  X64_0xA_igdkmd64+8d84f

BUCKET_ID:  X64_0xA_igdkmd64+8d84f

Followup: MachineOwner
 


#5
I can uninstall the integrated graphics all-together in the Add/Remove Programs section. Going to check on that now. I'll update in a little while. Just downloading Service Pack 1 (AGAIN!)
 


#6
In the most manly way possible...I LOVE YOU :D Well, I installed my graphics driver, and finally got not only to the login screen, but to my desktop! :D

Shouldn't get too excited just yet, just incase. But I'm pretty stoked about coming this far, as simple as the solution was. The annoying thing about all this is on both my old SSD and the temp HDD while waiting for this replacement, I had the Integrated Graphics Driver installed, and never had any issues with the nVidia Graphics Drivers before. I guess it was just fluffing me around this time eh? Or I installed the Integrated Graphics Driver AFTER I installed the nVidia driver (something I never done pretty much every time I had the BSOD).

Anyway, thanks man. I really appreciate it. And if I do get anymore issues (hope not!) I'll post the dumps here and see how people can help.

Thanks again! :)
 


Trouble

Noob Whisperer
#7
Glad to hear you are having a bit of better luck now. Thanks for posting back and updating your thread with your information.
Yes if Blue Screens persist just post the most recent dump files and we'll have another look.
Regards
Randy;)
 


#8
I had to install a different driver today to the one I got working yesterday. But it installed without any issues. So I'm pretty sure the Intel Integrated Driver was the issue. Still hoping for no issues, and thanks for all the help :D
 


Trouble

Noob Whisperer
#9
You bet and keep us posted. Lot of good people here who are lot better at getting to the bottom of these Blue Screen issues than I am, post back if anything else comes up, and ....
Good Luck
Randy
 


#10
Everything seemed to go well. Although, for My Music, My Pictures and My Videos, I made folders with exactly the same names, but it left behind folders on C that were titled just 'Music,' 'Pictures' and 'Videos.' Apparently, despite having 'My' in front of the 'videos' and 'pictures' etc. the locations for them was C\Users\Brett\Music and C\Users\Brett\Pictures etc. No 'My.'

Still, the folders moved fine. I'm just hoping that music knows to make it way to the correct folder when I copy a CD off. Thanks again dude :D
 


Elmer

Extraordinary Member
#11
The "My" is a legacy from Vista/XP. Theoretically, "My Music" will be "Music". A bit like Documents and Settings folder, you cannot access it, but you can through its real name of AppData.

It's for all those folks who upgrade so they can find their folders.

Now, If something goes missing,, that IS the time to worry!!

And, to be really honest, don't keep documents, music, pictures or videos on your system drive. Move them to another drive or partition away from your main system (C:) drive. :)
 


Last edited:
#12
Yeah, even though I have the remaining 'Music,' 'Pictures' and 'Videos' folders, I imported a couple of CDs to iTunes the other day, and the music made it's way to the right folder (the 'My Music' folder on D). So all it well! :D

Thanks for the replies again guys :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.