Is it possible to have a classic my documents folder?

Discussion in 'Windows 7 Help and Support' started by Bren86, Aug 10, 2009.

  1. Bren86

    Bren86 Senior Member

    Aug 10, 2009
    Likes Received:
    I'm not a fan of the libaries and the other junk in the left hand panel of the documents folder in windows 7. Can I change the my documents folder so its the same as the my documents folder in windows xp?

    When I click documents in Windows 7, it takes me to the documents sub folder in libraries which I don't want. I want it to take me to a normal documents folder like in windows xp and have it display sub folders for video, music and pictures etc all in the big white area.

    I haven't seen a classic view options for documents in Windows 7 but I tried to follow this guide to open documents as default rather than the libraries folder but it didn't work.

    #1 Bren86, Aug 10, 2009
    Last edited: Aug 10, 2009
  2. nunchuck

    nunchuck New Member

    Jul 7, 2009
    Likes Received:
    Hackr Solution

    Hi Bren86

    After Poking around for a couple minuets, I found a way to allow you to navigate to C:\users\your user name here\My documents\ when you click the documents link in windows 7 (from your Start Menu, Desktop, Ect.).
    Please note, the documents library will still be there in explorer (I recommend adding the "My Documents" folder to your explorer favorites.)
    Also note, this is a registry hack, not a windows 7 setting... Use at your own risk! (Worked for me :) )

    First, consider backing up your whole registry or making a restore point (99% unnecessary, as we are only changing a couple values, but I am highly paraniod... go figure...).

    Next, open regedit by typing it in your start menu.
    Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}.

    Export a copy of the whole key, just in case.:rolleyes:

    Delete Stream, StreamResource, StreamResourceType, and ParentFolder.

    Please Note: Don't include quotes in the text below when changing or adding values!

    Change RelativePath to "My Documents" (or documents, if you do not have a my documents folder in c:\Users\you user name here\).

    Change Name to "Documents".

    Change ParsingName to "::{59031a47-3f72-44a7-89c5-5595fe6b30ee}\{FDD39AD0-238F-46AF-ADB4-6C85480369C7}".

    Add a DWORD value "Attributes" and set to 1.

    Add a DWORD value "Roamable" and set to 1.

    Log off and on again or kill and restart explorer.exe. Enjoy!:D

Share This Page