Issues with installed drivers on system reboot

Discussion in 'Windows 7 Help and Support' started by Realist, Jul 20, 2012.

  1. Realist

    Realist New Member

    Joined:
    Apr 23, 2011
    Messages:
    14
    Likes Received:
    0
    Hello. I'm sorry to add yet another topic of which you've probably already seen for the umteenth million time today... But I was hoping to get some help, if possible.

    For a few months now, whenever I boot up it seems that all of the USB ports on the computer, including the network adapter just simply won't work until I've reinstalled. What's weird is this is true for all but one USB port, which is located on the back of the case. I've kept my mouse plugged in there so whenever I need to restart I can easily reinstall the drivers... And really it's not that big of a problem or anything, it's just become an annoyance at this point, you know?

    I've tried updating the drivers in question and it says they're up to date. I'm not sure what else I can do past that since I'm not that knowledgeable in this area. The drivers that are experiencing the problem I described are; "Realtek PCIe GBE Family Controller" -and- "Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26"

    Another thing I guess I'd like to ask about since I'm making this post... I have a USB port on the front end of the PC which won't work whatsoever even after reinstalling drivers. We had a power outage a while back, and I thought maybe it could have fried it or something... Any ideas for that?

    Thanks for taking the time to read. I appreciate any help. And if this is in the wrong place, please forgive me.

    PS If there's anymore information that I can give that would help, just let me know and I'll get right on it.
     
  2. alberto

    alberto New Member

    Joined:
    May 31, 2012
    Messages:
    248
    Likes Received:
    1
    Hi Realist, what did you try to update the drivers with? Did you have a look at the manufacturer's website yourself? Is this a laptop or a desktop?
     
  3. Realist

    Realist New Member

    Joined:
    Apr 23, 2011
    Messages:
    14
    Likes Received:
    0
    Thanks for posting, Alberto.

    The first time it happened all I did was pull up my devices in the control panel and troubleshooted the PC, which then told me that there was an error with those items I listed before. So I went into the device manager and just found both of them and clicked "update driver software," which I assume just installs the most recent software. Is that wrong? It's a desktop, by the way.

    And no I haven't tried looking at the website. I didn't even think about it until you mentioned it. I have no idea what to look for there.
     
  4. alberto

    alberto New Member

    Joined:
    May 31, 2012
    Messages:
    248
    Likes Received:
    1
    Well, I've never found myself in a situation where I needed to update drivers and didn't have the manufacturer's installer so I can't be sure if the device manager's "update driver" button works properly or not. However I am quite skeptical it is quite as good as downloading and installing it yourself.
    The easiest way to find the correct drivers if the PC was built by somebody else is to go on their website and enter some sort of computer service number or the model number. Either should be found somewhere on your case. On a sticker or printed on the case itself.
    If the PC was built by a friend or a local IT shop it might get more complicated...
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    A little more info about your system might help.

    Were you involved in the recall of the Motherboards with the SATA problems? You seem to have a H67 or possibly some other letter designation 67 chipset.

    You should be able to get chipset drivers from the manufacturer, or even Intel. If you have such things as USB 3.0, that is probably an additional driver. But, as you mention, it is not normal to have to reload those drivers. Chipset drivers are not easy to uninstall, but you could uninstall your Network adapter and see if it comes back and works normally.

    Do the USB ports work before you get into Windows, or have you tried running something like Linux to check the operation of the motherboard? You can boot directly to it for testing. What color is the USB port on the back that works, or is it a different color from others?

    Electrical disruptions can cause damage..testing from outside Windows 7 will help make that determination. If it was just a loss of power and not some type of surge, it might have messed with the Windows install.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Something else you might do is to have Msconfig.exe make a boot log of your system boot. From that, you may be able to tell if the specific drivers are being loaded or having some type of problem.

    Open MSconfig.exe and go to the boot tab. Check the Boot log box and click apply. After you boot once, you may want to uncheck the box to keep the file from being overwritten, but if you copy it to the desktop, you will be able to keep it.

    After you reboot, look in the C:\Windows directory for ntbtlog.txt and copy somewhere. If you want, you can attach using the paperclip on the advanced replies or check it yourself. The drivers you are looking for can be found in the Device Manager, in the properties of each device. Look in the Driver tab, Driver Details button and see what .sys files are listed.

    For instance, on my system with a Intel 82579V adapter, it is e1c62x64.sys. For other devices, such as a USB hub, it may be several drivers, like pci.sys or usbhub.sys type of things.

    Anyway, you could check the log and see if they show up and what might be happening to them.
     
  7. Realist

    Realist New Member

    Joined:
    Apr 23, 2011
    Messages:
    14
    Likes Received:
    0
    @Alberto

    This PC was built by the manufacturer. Fortunately I don't have to worry about that. I'll go online and look around and see what I can find out about it.

    @Saltgrass

    Thanks for taking the time to reply.

    To be totally honest with you, I'm really not that computer savvy. I can tell you though that this PC is fairly new and was not involved in any sort of recall. I'm not really sure how to check and see if what I have is USB 3.0 or not. I can tell you though that I did try uninstalling the network adapter and reinstalling it and it still showed the same issue.

    I haven't tried using the ports before windows starts or running Linux. I haven't the slightest clue how I'd even begin to do something like that. Unfortunately, I think that's a bit beyond me. It may very well come down to that, though. I can tell you that the USB port that does suspiciously work (on the back of the tower) is not colored any differently or distinguishable in any way from the other ports. They all look exactly the same, front and back.

    I did make a boot log as you said though and this is what the result was;
    View attachment ntbtlog.txt

    In the log it clearly repeats the lines; Did not load driver \SystemRoot\SysWow64\drivers\libusb0.sys, Did not load driver \SystemRoot\System32\drivers\dxgkrnl.sys, Did not load driver \SystemRoot\System32\drivers\vga.sys, Did not load driver \SystemRoot\System32\Drivers\NDProxy.SYS and Did not load driver \SystemRoot\System32\DRIVERS\srv.sys

    Indubitably, this is probably the problem I'm facing.

    Let's say I identified each device in the device manager using this information, where should I go from there?

    If there's any more information I could provide that might help I'd be glad to.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I am going to have to suggest the libusb0.sys driver is related to your problems. Since we still do not know what type of system you have, I can just say I do not have the file on my system. If you know what utility is loading it, maybe you can uninstall that utility to see if it helps. I suppose also, if it is a necessary file, it might be corrupted.

    I can't really find out what the file is, but it appears to be something related to a Linux type file, possibly an Apple install. But if it is required by your system, it does not appear to be loading. If you can find a place to download it or another source, you might try replacing it, but there may be security issues that would have to be dealt with in order to do so.
     
  9. Realist

    Realist New Member

    Joined:
    Apr 23, 2011
    Messages:
    14
    Likes Received:
    0
    I searched for the file and found it in my SysWOW64 folder in the Windows directory. It has a file description of "Lib USB-Win 32 Kernel Driver." Of course... I have no idea what that means or what it could be used for. Would that be considered an essential file? And how would I go about finding what utility is loading it? I'd rather not fiddle with it before I know what it's used for because I don't want to mess anything else up.

    As for information on my system, what in particular do you need to know about it? Without pulling anything up, I can tell you it's an HP, model p6-2033w with a 64bit OS. If what you need is more detailed than that, then just tell me what it is and I will find a way to retrieve that information.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I went to the HP site and found this link about troubleshooting USB problems. If the link does not work, it was in the Support section for your system.

    Troubleshooting USB Connections (Windows 7) HP Pavilion p6-2033w Desktop PC - HP Customer Care (United States - English)

    The libusb0.sys seems to be part of a USB driver system to replace the normal USB drivers. I am not a programmer, so not really sure, but it may be something you added somehow, or possibly HP installs it on their systems. The troubleshooter may help sort this situation out.

    libusb-win32

    The fact your network driver is not working would not seem to be related, unless there was a problem with the system regarding something like a PCI bus that might handle both devices. The HP site does not seem to show drivers for anything other than your sound, video, and SATA devices. I suppose HP relies on Windows 7 to handle the rest.

    Let us know if the troubleshooter finds anything.
     

Share This Page

Loading...