Java will not Install on my Windows 10 Machine


New Member
Hello there! I've been having a very frustrating issue with installing Java on my (fairly) new Windows 10 64-bit machine, and any assistance in this matter would be so very much appreciated. I've searched all over, and posted in several tech forums searching for help, all to no avail. So any help or suggestions at all are welcome, and I am so grateful for them.

On my previous version of Windows (Windows 7 64-bit), I had Java (32 bit and 64 bit) installed, and it worked perfectly. However, I can not for the life of me get it to install on my current machine, no matter what I do, and I have spent the better part of a week trying to find someone who's having the same issues I am, or fix the problem myself, both to no avail.
So I turn to the experts on this forum.

To describe my problem in much greater detail:

I downloaded the offline installer for Java 32 bit, and 64 bit, from the manual download page.
Upon trying to run the 32 bit installer (which you are supposed to install first), nothing appeared to happen. So I left it for about 20 minutes, and found it still wasn't doing anything when I came back. So I brought up my task manager to check if anything was running in the background, and found "Java Platform SE Binary (32 bit)" running there. As it appeared to be doing nothing, I ended it, and tried running it again, only for the same thing (nothing) to happen.

I then tried the 64 bit installer, thinking maybe something had changed, and Windows 10 just didn't need the 32 bit version (upon later research finding that this is an incorrect assumption on my part). Same story with the 64 bit installer as well.

Frustrated, I tried to search my computer, to see if it had added anything. There were no new program entries, and no Java section in my Control Panel, but there was a new folder in my Appdata, LocalLow, called "Oracle," containing a Java folder, with a "jre1.8.0_65.msi" file.
I tried to run the MSI file, but got the following message:
"There is a problem with this Windows Installer Package. A program required for this install to complete could not be run. Contact your support personnel or package vendor."

I tried Oracle's official help on this matter, but none of the listed steps, even all used in conjunction, did anything.

I also tried their online installer, rather than the offline one (even though I need to use the offline ones in the end, because I need 64 bit), and it had the same issues.

I tried searching all over to see if someone was having this same issue, but I could only find similar ones, and even upon trying their solutions, I still couldn't get it to work.

In short, I run the installer, and nothing happens, no window, no errors, it just runs in the background indefinitely. I have tried installing in safe-mode, verifying/repairing my system files, running the installer in all available compatibility modes and as administrator, turning off my firewall and anti-virus softwares, and nothing has worked thus far. I'm out of ideas.

Thank you very much for any and all assistance, it is much appreciated.


Fantastic Member
Premium Supporter
Hi and welcome to the forum;

sorry to hear about your problems with your Java. I've seen this problem on earlier versions of Windows and there are set solutions to fix this. I have not yet seen it on any of the several W10 installs I have done on my machines. but first, it would be helpful for you to provide the exact make/model of your computer for us. Is it a desktop PC or a laptop?

Once we know this information, we can advise you better.

Also, it would be helpful for you to download the free SPECCY diagnostic from and post the text file result back to this forum thread. This will give us more information on your hardware and software environments to make a custom diagnosis for you.



New Member
Woohoo! I just got a reply on one of the other forums I previously posted in, with a solution that appears to have worked!

Sorry to bother, I'm super grateful for your responding so quickly to assist.

For future reference, if anyone ends up finding this thread and is having the exact same problem, I fixed it by installing the JDK version, then just uninstalling the Dev Kit part of the install, leaving me with just the proper Java Runtime Environments.


Fantastic Member
Premium Supporter
It's no problem. Glad you got it resolved; and thanks very much for posting your final result back here to the forum for other Users to benefit from your solution. :applaud:

Have a great week!