LAN-connection does not have a vailid IP-configuration

Bart

New Member
#1
Dear all,

Yesterday, I upgraded my Compaq laptop (bought 1 month ago) from Vista Ultimate to Windows 7 Ultimate.

When the update was finished, it was not possible to connect to the internet anymore. I am using a wired broadband connection. I tried both with and without the interference of the router. However, the problem of not recognizing the network remains.

I run the problem solving program, which suggested to switch off the modem and to disconnect the wires for aprox. 5 min. This didn´t work. The program then said that my LAN connection doesn´t have a valid IP configuration, but doesn´t give me a solution.

My IP-adress is 169.254...... Which I guess, is not right....? I made sure that the laptop "obtains IP-adress automatically"....so I just don´t know what to do anymore.....

I really hope that someone is able to help me. That would be just great!!

Thanks a lot!

Regards,
Bart
 


#2
Are you directly connected to your cable modem? I have had numerous problems with 'no valid IP configuration' errors myself. Sometimes I have to go click on the 'Local Area Connection' and then 'Diagnose', this resets the adapter and usually works. If that doesn't work then I will manually input my ISPs DNS server addresses and then 'Diagnose'. I updated my LAN drivers to the latest from Nvidia website and have had no problems since.

Try opening a command prompt and type in -

Code:
ipconfig /flushdns
ipconfig /registerdns
ipconfig /renew
Hopefully that works :)
 


Bart

New Member
#3
Thanks for your help Gavin!

Well, I tried the "Diagnose" several times already, but this didn´t help.

I don´t understand what you mean by manually putting in the ISP´s? DNS? What is that?

I tried typing in the commands flushdns and registerdns, but the problem stayed the same. The ipconfig/renew is not accepted. It sais then, that it can not change anything on a Wireless Network when this network is not connected..... I do not understand this, as I am not trying to connect any wireless connection. After 2 minutes, the message appears saying: A problem occured while renewing this interface: LAN-connection, cannot contact the DHCP-server. Request has expired.

I tried connecting directly to my modem and by using my router, however, the problems remains the same....still no internet for me....
 


#4
The 'ipconfig /renew' command will attempt to renew all connections, that's why it gave you an error regarding wireless. By entering my ISP's DNS server addresses manually it has helped me get a connection. Google for the DNS addresses for your ISP and then enter them into the 2 allotted slots below IP configuration. This has helped me get a connection in the past when everything else failed. This is how mine looks -



My DNS addresses won't work for you but it's just to show you an example. Also tick the 'Validate..' box as shown so that it detects the changes. There could be many reasons why you can't connect like your firewall etc, but you should try to update your drivers for your chipset/LAN as the upgrade from Vista obviously hasn't worked out.
 


Bart

New Member
#5
Thanks again Gavin

The only thing is, I´m not that good with computers, so I don´t know how to "google" the DNS for my ISP.... As I actually don´t even know what DNS or ISP is....

At the moment I do not have anything like a firewall working, as my firewall got disabled when I did the upgrade.

And how do I upgrade drivers? What is chipset/LAN? And is that possible without internet? Or do I have to do that with the PC I´m using now and than put it on a disk or something?

Sorry for being so bad at this!
 


#6
Download CPU-Z and start it up. Click on the 'Mainboard' tab at the top and this should provide you with all the relevant details. Take a picture of it using the Snipping Tool, under All Programs > Accessories and attach it to your next post. Then we can set about updating your drivers which should hopefully fix things :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.