Laptop can't see other computers in network

Discussion in 'Windows 7 Networking' started by xMrFlipFlop, Aug 13, 2011.

  1. xMrFlipFlop

    xMrFlipFlop New Member

    Joined:
    Aug 13, 2011
    Messages:
    4
    Likes Received:
    0
    I have a home network that has been set up on a modem with internal router for ethernet ports and wifi. When computers connected to the modem via ethernet cables, they can easily discover each other through the 'network' icon. But when I connect my laptop to the network's wifi, only the desktop computer can see the laptop in 'network' and not the other way. The laptop can't see any computers. When I tried to connect/open the laptop through the computer, error code 0x80070035 network path not found came up.

    I tried pinging the computers (both with ip address and name), and heres what happened:
    -when I ping desktop to laptop, it didn't work
    -when I ping laptop to desktop, there was response. Then the desktop showed up on the laptop's 'network', and I can view/transfer shared files. desktop can also connect/open the laptop's shared files. Pinging from desktop to laptop also works.

    I've checked things like firewall, make computer discoverable in network, services. They all make no difference to the situation. Where unless if I ping the desktop from my laptop, the desktop won't show up and file sharing won't work.

    Can anyone help me with this?

    Thanks in advance

    =edit=
    it seems that I have to constantly ping the desktop or the "connection" would be lost. :/
     
    #1 xMrFlipFlop, Aug 13, 2011
    Last edited: Aug 13, 2011
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    xMrFlipFlop:
    Hello and welcome to the forums.
    On all computers on your network
    type
    ncpa.cpl
    into the search or run box and hit enter
    select then right click the network adapter you are using on the network and choose properties
    select (highlight) Internet Protocol Version 4 and click the properties button
    then click the advanced button
    then select the WINS tab
    select the radio button that says "Enable NetBIOS over TCP/IP
    OK your way back out of there.
    Type
    services.msc
    into the search or run box and hit enter
    scroll down and find
    TCP/IP NetBIOS Helper
    double click it
    Set the startup type to automatic and click the start button
    Same with Computer Browser Service
    You didn't say what computers are on the network but if involves any XP machine. Shut down all the computers after performing the above steps and bring them up one at a time Windows 7, Windows Vista, and XP last.
    Good luck and keep us posted
    Regards
    Randy
     
  3. xMrFlipFlop

    xMrFlipFlop New Member

    Joined:
    Aug 13, 2011
    Messages:
    4
    Likes Received:
    0
    thanks, worked. =]
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good, glad.
     

Share This Page

Loading...