laptop touchpad not working with windows 7 (7000)

Discussion in 'Windows 7 Help and Support' started by younggotti, Jan 6, 2009.

  1. younggotti

    younggotti New Member

    Joined:
    Jan 6, 2009
    Messages:
    2
    Likes Received:
    0
    hey does anyone else have this problem where their laptops touchpad is not working with the 7000 build of windows 7. its a toshiba laptop. i tried to install the touchpad driver for it, and it shows that the device is working properly through the device manager, but nothing happens. ive tried turning the touchpad on and off and it still does nothing. the mouse worked perfectly fine when i had xp installed on it, but once i changed to windows 7, it just stopped working.

    i was just hoping that somebody else maybe had this problem and found a way to fix it. other than that its a good os. really big upgrade over vista.
     
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    My Acer touchpad works by default. I have no idea on the Toshiba, but I googled and found there did seem to be touchpad problems, even with Vista.
    I did find this. It is referring to one function, but might lead you to a solution?
    "I have a Toshiba Satellite 1905-S301 with the ALPS touchpad, and I
    > cannot disable tapping!
    >
    > I have re-installed the ALPS driver and the "Touchpad Enable/Disable"
    > utility, but still when I go to Control Panel/Mouse, there are no
    > options relating to "Tapping" at all.
    >
    > Has anyone else had this problem?

    Seems like it was buried deep inside for my A75-S206.
    Control Panel/Mouse/Touchpad on-off/Advanced/TouchPad tab/Pointer Speed
    and tapping settings box/Settings/Uncheck Tapping: Enable Tapping
    "
     
  3. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Actually I deliberately disable mine. Without that my cursor randomly jumps all over the place making data input almost useless.

    99% of laptops in the known universe use some sort of synaptics driver. Download the generic synaptics driver from the synaptics site -- choose the 32 / 64 bit version depending on which W7 you are running. You've now got a whole lot of choices as per screen shot.

    Cheers
    jimbo
     
  4. njek

    njek New Member

    Joined:
    Jan 18, 2009
    Messages:
    30
    Likes Received:
    0
    I have a Toshiba laptop, and the touchpad is working 100% under W7...

    Obviously had to d/l touchpad driver to get scrolling working, but touchpad itself was working as soon as W7 was installed
     
  5. slowtype

    slowtype New Member

    Joined:
    Jan 15, 2009
    Messages:
    38
    Likes Received:
    0
    I had/have some problems with my dell touchpad. I downloaded the latest drives from synaptic which helped for a little while. I ended up having to use the Dell synaptic drivers from another model laptop that comes with 64 bit operating system. But still occasionally when I boot the computer the drivers do not load or something and the touch pad is INOP.

    I would try another source for your touchpad drivers.
     
  6. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    I downloaded and installed the TrackPoint/TouchPad UltraNav drivers from Lenovo for my T42 ThinkPad. Work fine: I was able to disable the TouchPad with them (I did it because I hate the TouchPad and prefer the TrackPoint only). I've now got TrackPoint scrolling working with the UltraNav drivers as well.
     
  7. Tonanti216

    Tonanti216 New Member

    Joined:
    Dec 6, 2009
    Messages:
    2
    Likes Received:
    0
    synaptics touch pad

    I have part of this problem with a Toshiba L450 running Windows 7 Home Premium - the touch pad allows me to scroll, drag and all functions EXCEPT tapping! I have tried resetting to "default" but have not yet attempted to uninstall the driver and restart... I am not sure what will happen if I do. I have run troubleshooting and the response is that the pad is working correctly.... just can't tap. The feature to set this is greyed out in the settings also. Tapping just stopped one day. Any ideas?
     
  8. otoomuch

    otoomuch New Member

    Joined:
    Dec 15, 2011
    Messages:
    4
    Likes Received:
    0
    Warning this uses regedit and can mess up your system. Have someone else do it if you don't feel comfortable about editing

    your registry. Smarter people than I may be able to cut out some steps and this process might be applied to other drivers. I

    am not a computer expert! Well, this is how I got my Synaptics ps2 touchpad to work on my Benq. I hate Synaptics now and I

    will never buy a computer that has a synaptics device again. The basic problem is that I believe since Windows XP service

    pack 3 you MUST HAVE A SIGNED SET OF DRIVERS or it won't install and run on your system. Sure the programs installs it, but

    windows won't recognize it! So you delete the driver and reboot. Humm, windows7 identifies a mouse, not a touch pad so it

    installs the wrong driver- and guess what..its not signed and you are back to square one. What worked for me. Logon as a user

    with administator rights. Step 1. Download and install the "Universal Extractor" from FileHippo

    Download Universal Extractor 1.6.1 - FileHippo.com Step 2. Download but do not install the windows 7 version of the

    synaptics driver. Drivers | Synaptics Step 3. Go to control panel-progams and feature and uninstall

    anything synaptic Step 4. Reboot Step 5. Go to control panel-system-Device manager-View and check -Show hidden devices. If

    something new shows up under mice and other pointing devices. Right click and delete the device/drivers. Step 6. Boot to safe

    mode Step 7. Start regedit Step 8. Use the search to find synaptics check whole word option. Step 9. Search and delete

    anything that shows up until the search doesn't find any more locations. Step 10. Reboot back to safe mode Step 11. Go to

    control panel-system-Device manager-View and check -Show hidden devices. (Make sure you don't delete the HID mouse!) If

    something new shows up under mice and other pointing devices. Right click and delete the device/drivers. Step 12. Find the

    file you downloaded from synaptics, right click on it and look for the option - unextract to subdir. It will ask which mode

    to use-pick- "not an install shield" and extract. Step 13. Open the new file directory-

    Synaptics_v15_2_20_C_XP32_Vista32_Win7-32_Signed_Marketing_SGS94_UI-Scrybe and click to run dpinst.exe This will install the

    SIGNED drivers you need without all the other **** from synaptics. Step 14. Reboot and go to the logon that gives you

    administrator rights. Step 15. AGAIN-Go to control panel-system-Device manager-View and check -Show hidden devices. Something

    new should show up under mice and other pointing devices- PS2 touch pad. Right click and read the device/drivers details, it

    should say you need to reboot to activate the new drivers. Last Step- Reboot, unplugging the usb mouse you were no doubt

    using, before windows starts and PRAY. Good Luck. Mine works now after 3 weeks of trying. I tried almost everything including

    signing the old drivers using a 3rd party signing program. This is the only thing thats worked. Good Luck By the way, I used

    to trust FileHippo downloads. Now several of their programs are installing **** that you don't want! Make sure you read the

    agreement until the end or you will be signing away your bandwith to various advertisors in a very sneaky way. I have found

    the "free" pdf programs to be especially dangerous.
     

Share This Page

Loading...