Letters turn to numbers?....

Discussion in 'Windows 7 Help and Support' started by thehelpless, Oct 31, 2010.

  1. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    Well, whenever i play a fullscreen game like left4dead or modern warfare, the letters on the keyboard turns to numbers. for example whenever i press w or r it changes to a random number 0-9.
     
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    Does it do this for all games you play?
    And what kind of keyboard do you have, is it one of those programmable ones?
     
  3. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    no only just those two games. and i dont know if its programmable ones...it came with the computer.
     
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    Hi

    Try and turn off, "Numlock" and see if that changes it.
    On keyboards that so not have a Number Pad it can change some letter keys to numbers when Numlock is turned one.
    This may have something to do with that.

    Mike
     
    #4 MikeHawthorne, Oct 31, 2010
    Last edited: Oct 31, 2010
  5. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    this keyboard does have an number pad and i tried turning off numlock. It doesnt work.
     
  6. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    Is this a desktop or a laptop?
     
  7. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    this is a desktop.
     
  8. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    I don't have a clue if it has nothing to do with numlock.
    You could try running the game in Windows view so that you can minimize it and check to see if the game changes the Numlock setting when is starts.

    On laptops this can be solved by hitting the FN key or the FN key with the Numlock key but since it only does it in the game the game has to be changing something.

    Mike
     
  9. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    The keyboard has a FN key. When i go into left4dead/modern warfare console, it types perfectly. it only happens ingame.
     
  10. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    Look at the keyboard and see if the keyboard setup changes when the game is running.
    I have had games that turned my numlock key on or off, I have no idea why.

    Do you mean that when you are in Windows mode it is OK but in Full Screen it is not?
     
  11. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    When i have the game running and i alt+tab out of it, it types perfectly. the problem only exists when im playing the game (ex. trying to move the character).
     
  12. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    So you are not trying to type in the game, you are using the WSAD keys to move the character around.
    And that's not working?

    Look at the mouse options in the game and the key settings and see if the settings agree with what you are trying to do I.E is W set for move forward, S back etc.
     
  13. thehelpless

    thehelpless New Member

    Joined:
    Oct 31, 2010
    Messages:
    14
    Likes Received:
    0
    i figured out what was wrong with modern warfare. when i tried to start mw2 up it told me "Do you want to optimize your setting to fit your computer?" i selected no and it works perfectly. I still dont understand what's wrong with left4dead...
     
  14. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,053
    Likes Received:
    303
    It's weird, I've been a gamer for decades and I have never run into this problem.

    I don't have any other ideas I was sure that it was probably because the game was turning numlock on or off.
     

Share This Page

Loading...