LG L222WS Monitor

Funk

New Member
#1
I have L222WS Monitor, and the best resolution for it is 1680x1050, but i can't get it. Currently it's set on 1600x1024, and the screen is kinda blurr-ed. I cannot install drivers and find any suitable for windows 7. I cant change it to 1680x1050 becouse i cannot find it on the list. I have nVidia 8800GT and installed drivers, and the option custom resolutions it's not working, i would like to manage the resolution, but i cannot find the way to do it.

Thank you
 


reghakr

Essential Member
#2
Did you use the Windows Update model through Windows update?

I'd recommend going tho NVidia's site and look for Windows 7 drivers here:
Drivers - Download NVIDIA Drivers
 


reghakr

Essential Member
#4
Try this utility and see what modes are supported:

Download System Information Viewer

Click on the Video entry, then the Modes
 


#5
I sort of have the same problem. I just have a Samsung T220 instead and a Geforce GTX 260. When I go to change the resolution, it only goes to 1280x1024 (where 1680x1050 is best for the monitor). I have updated Windows7, installed the latest Nvidia driver (185.85) and I have manually installed the Samsung T220 analog drivers, as Win7 will not execute the driverinstallation on the CD (have tried in compability mode etc, no luck). It is connected through analog cable.

It really is the weirdest thing. It works beautifully on my XP computer. It is like Windows 7 will not recognize my 22" screen as widescreen, and furthermore won't go to higher resolutions than 1280x1024. It is really starting to annoy me. I haven't found anything on this subject, where a solution has been found. Just seems Windows 7 and 22" monitors are a bad mix.

Also, I tried that programme that reghakr recommended, but I couldn't find the "video" entry anywhere. Could you be more specific on where to find this?
 


reghakr

Essential Member
#6
The mode location is under Hardware > Video > Modes.

i have 2 22" wide screens, one DVI and one analog and have have no problems at all.

One is a cheap Nvidia integrated 6100 nForce with 128MB memory

The other is a GeForce 8600GT with 512 MB memory
 


#7
The mode location is under Hardware > Video > Modes.
I haven't got this option, for some reason. I run version 3.36 of the SIV?



I think it all comes to down the Samsung driver, that won't install. Right after I installed this on my XP computer, I could change the resolution to the recommended 1680x1050. But Win7 won't have anything to do with it. It's the only thing making me want to install Vista (eurgh) and XP 64bit is so buggy, it won't even install Live Messenger (eurgh x 2). I have installed the driver manually though, but I don't think it's making a difference.
 


Last edited:

reghakr

Essential Member
#8
Sorry, my mistake.

Download SIV (System Information Viewer) 3.36

You are using a similar program called SIW.

Please fill out your computers specs in the User Control Panel here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.
 


Last edited by a moderator:
#9
Feel more than free to call me stupid but appears to be the same exact programme. I did however fill out that information :)
 


#11
I have L222WS Monitor, and the best resolution for it is 1680x1050, but i can't get it. Currently it's set on 1600x1024, and the screen is kinda blurr-ed. I cannot install drivers and find any suitable for windows 7. I cant change it to 1680x1050 becouse i cannot find it on the list. I have nVidia 8800GT and installed drivers, and the option custom resolutions it's not working, i would like to manage the resolution, but i cannot find the way to do it.

Thank you
Hi Funk;29582, I have the LG L224WS Monitor, a later version of your L222Ws monitor. I am having the exact same problem and have gone bald pulling my hair ovevr this problem. Could you let me know how you fixed this issue?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top