Libraries are not visible

#1
I have a Dell XPS L702X running Windows 7 Home Premium 64 bit, within the explorer window there is a link on the left for Libraries but when you click on it there are no libraries displayed, the window is empty.
The Libraries do exist as you can see them in the 'Include in library' dropdown.

Ive looked around and i have seen that this is an issue for 64 bit but i have no idea of how to get them to appear.

Any help is much appreciated.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
If you look at the Include in library drop down, does it show My Documents or Public folders? Have you selected to include those in the library?

You may need to go the the documents folder in Users\YourUser and right click there and select "include in library"
 


Last edited:

Trouble

Noob Whisperer
#3
Another option might be to;
In the left column (navigation pane) right click Libraries and choose "restore default libraries". Might work?
 


#4
In the include in libraries drop down i have 5 options:
  • Documents
  • Music
  • Pictures
  • Videos
  • Create new library
If i go to My Documents ans select Include in library i get an error saying 'My Documents is already included in the library'.

I have already tried the restore default libraries option and it didnt change anything.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
OK then, possibly try removing them so you can re-add later...

Does it make any difference if you Shift+right click the explorer icon in the Taskbar and select "Run as Admin".

I don't seem to show and "Include in Libraries" option for the "Libraries" folder, only for the libraries themselves.
 


Attachments

Last edited:

Trouble

Noob Whisperer
#6
If you could provide an image of what exactly you are seeing as saltgrass has so we know we are talking about the same thing.
Additionally if we are talking strictly about the left column (navigation pane) then perhaps open the libraries folder and right click each individual library Docs, music, pictures, etc., and choose show in navigation pane.
 


#7
Ive tried to open as administrator and i still get the same result.

Ive attached two screenshots.

The first one shows the Libraries window, as you can see there are no libraries visible.

No Libraries.gif

The second one shows how i was selecting include in library, as you can see if i navigate to My Documents there is an option to Include in Library and in the drop down you can see all of the libraries that you would expect to see but if i select Documents it tells me that its already part of the library.

Include in library.gif
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#8
Something you can try. The AppData folder is hidden, so replace YourUser with your user name and paste it in the address window.

C:\Users\YourUser\AppData\Roaming\Microsoft\Windows\Libraries

Are there any entries in this folder? You should have the four default libraries. If you do see them, right click and select properties. On the botton of one tab is a checkbox for "Include in Navigation pane". Make sure it is checked. Or there might be an option in the right click menu for this.

If nothing shows in the Libraries folder, right click on the Libraries folder and select Restore Previous from here. Maybe that will jog it some.

If you do not show any entries, go back to the libraries folder and select "Create New Library". Name it Documents and open the properties. Then on the libraries tab and set it to documents instead of generalized.

The icon is another problem, but it should work and hopefully the icon will return or can be set after you log out or reboot.

Are you using any software to modify the normal Windows 7 presentation?

The Favorites entries come from C:\Users\YourUser\Links folder. If you want to remove them, just delete or remove from the Links folder.
 


#9
I have naviagated to C:\Users\YourUser\AppData\Roaming\Microsoft\Windows\Libraries and there are no libraries in there. I have clicked on restore default libararies but nothing happens.

I have tried to cfreate a new library called Documents but i get a message saying that a library called Documents already exists.

I have even created a new library called Docs and as soon as i set the type to Documents it has disappeared.

My thinking is that this has something to do with 32bit and 64bit..... Im not an expert so im not sure.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#10
Well, I have been testing different scenarios trying to get your system back to normal, but have found nothing. I think we would agree your situation is not normal, so unless you have some third party software influencing your picture, I would suggest two things. If the first does not work, then surely the second will.

Open an Administrative command prompt and type sfc /scannow hit enter and let it run. Maybe it will find something and replace it. If you do not get a "could not repair" type of message, and your system still does not work after a reboot, then go to the next suggestion.

You can do a Repair Install and keep all your settings and programs. If you have something other than a retail install DVD (and maybe even if you do) you might want to change the install media in case there is something wrong with the one you used first.

The question about x86 or x64 would not seem to be relevant since I have both and not seen your problem. I do not really think a video driver update would help, but considering you are not seeing something that is supposed to be there, maybe it would. If you are on a laptop, you might even want to try an external monitor.
 


Last edited:
#11
I thank you for your help but im not sure if i want to go down such a drastic route just yet, being as ive only had the laptop for two weeks. I will put a call into Dell and see if they can find a cure, i noticed something on my searches suggesting that it may be something to do with the registry key entries.
 


#12
My libraries disappeared from the navigation pane shortly after I installed McAfee total Protection. There is an issue with the program that it changes folders to hidden. You might check McAfee forums if you are using that program.
 


#13
Yes i have got McAfee, thanks for your response.

Did you resolve the issue?
 


#14
Apgriffiths,
Yes, I seem to have solved the problem, at least for now. On one computer I used a fix posted by Brink on Sevenforum which required an entry in the command prompt (search " fix hidden empty libraries"). On my other computer I used a fix found in a McAfee forum which required a registry edit. Time will tell if either one is a permanent fix.

-- sorry if it is bad form to mention another forum, but this one didn't have a fix I was comfortable with.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#15
LaurieB, so you basically removed the Hidden attribute the folders McAfee had hidden.

Setting the view options to see hidden files and folders, would have made the folders visible. After that right clicking and selecting properties, and then unchecking Hidden would have put the files back (may require a reboot). Sorry I did not suggest allowing the viewing of hidden folders to apgriffiths.

The McAfee correction, which says they are going to provide and update to fix, involves changing the registry to keep future problems from occurring, but not fix the current ones.

Thanks for the response.
 


Last edited:

McoreD

Honorable Member
#16
Ive tried to open as administrator and i still get the same result.

Ive attached two screenshots.

The first one shows the Libraries window, as you can see there are no libraries visible.

View attachment 14639

The second one shows how i was selecting include in library, as you can see if i navigate to My Documents there is an option to Include in Library and in the drop down you can see all of the libraries that you would expect to see but if i select Documents it tells me that its already part of the library.

View attachment 14640
I have the same exact problem in this DELL L702X laptop.



Had McAfee which I uninstalled on day 1 but seems like having its effects.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#17
You seem to have a different problem. Can you right click on the library folders one at a time and select "Show in Navigation Pane"?

If that doesn't work, make sure you set the folder options to view hidden files and folders.
 


McoreD

Honorable Member
#18
Actually as soon as I unhid the folders they were visible in Library! So they were hidden by McAfee :)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#19
Very likely they were, but the OP did not show any folders under the Libraries--they were hidden and I did not see you say you had already unhidden them.

Did showing them in the Navigation pane help?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.