Local DLLs not loading

Discussion in 'Windows 7 Help and Support' started by astropirit, Jan 5, 2010.

  1. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    I have two DLLs named ws2_32.dll and wsock32.dll. I also have an application that i want to utalize these two dlls rather then the ones in system32 but it apears that it doesn't. I ran a dependency scanner and found that in fact the application does load these two DLLs rather then the ones in system32 folder.

    How i know its not working: the dlls are suppose to make a .cap file logging the packets sent and received in tcp dump format. It succeeded in making the .cap file on winXP but not Win7.
    I came upon some one else having same problem but with vista but that could be fixed by doing the following:

    'set the registry key "HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\DevOverrideEnable" to 1" '

    However, i can't find the DevOverrideEnable field in my win7 registry. please advise.

    Thank you,
    Astropirit
     
  2. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    i tried but it still doesn't work. i treid it again on XP and it works but not win7. must be some new security feature that needs to be dealt with.
     
    #2 astropirit, Jan 5, 2010
    Last edited: Jan 5, 2010
  3. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    If DevOverrideEnable doesn't exist in the registry, you can simply create it (as a DWORD value) with the string value set to 1.
     
  4. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    i allready tried making the field my self and restarted but it gave no results :-(
     
  5. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    What is the application that is attempting to utilize the DLL's?
     
  6. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    its a game server. but its not just that application, it doesn't work with any thing. and on xp it works for everything. both of my Xp and win7 are 32 bit so thats not the problem. i bet its some new windows security thats preventing this
     
  7. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    I'm going to assume judging by the advanced troubleshooting you already tried, that you've already tried running the App as an administrator?
     
  8. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    yes i am trying it on an admin account
     
  9. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    I mean right clicking the program and selecting the option "Run As Administrator"
     
  10. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    I really was hoping that it would be something simple as that and i would feel foolish and be on my marry way but :-( it didn't work
     
  11. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    What about running it in compatibility mode for XP? Right Click on it and select "Troubleshoot Compatibility"
     
  12. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    still no good. i still believe that i have disable some kind of security system for it to star working.
     
  13. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
  14. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    sorry if its a pain dude, but that didn't work. i have been trying for the second day strait with no luck
    any other ideas?
     
  15. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
  16. astropirit

    astropirit New Member

    Joined:
    Jan 5, 2010
    Messages:
    18
    Likes Received:
    0
    i am afraid that is not an option as i am developing software and require the use of this dll. does the registry entry " HKLM\ SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs" have any thing to do with this problem? i tried taking off the dll with the same name off the list but it denied my permission.
     

Share This Page

Loading...