Windows 7 Local Host runs so slow on Windows 7

Discussion in 'Programming and Scripting' started by chobo2, Sep 13, 2009.

  1. chobo2

    chobo2 New Member

    Joined:
    Jun 26, 2009
    Messages:
    40
    Likes Received:
    0
    Hi

    I switched from Xp to Windows 7 Pro. Since then I noticed when I run my website(asp.net mvc) in local host it goes so so slow(I mean like 10 to 20seconds per page).

    This should not be. I then tested it with sloppy to mimic a user of 256kb and it loads up alot faster(maybe 2-3seconds at most).

    I then changed my localHost to 127.0.0.1 and it goes super faster. It just when I use localHost it goes this slow.

    Anyone got any ideas why this is happening?
     
  2. epk1950

    epk1950 Banned

    Joined:
    Sep 1, 2009
    Messages:
    524
    Likes Received:
    9
    Could it be DNS Client service bogging you down?
     
  3. chobo2

    chobo2 New Member

    Joined:
    Jun 26, 2009
    Messages:
    40
    Likes Received:
    0
    I would not know. How do I tell?
     
  4. epk1950

    epk1950 Banned

    Joined:
    Sep 1, 2009
    Messages:
    524
    Likes Received:
    9
    When you use the localhost.
    Disable DNS Client under Services.
    "windows key"
    Code:
    Host key + R 
    them 2 pressed brings up run.
    type in
    Code:
    services.msc
    Locate
    DNS Client
    Right click on it, Properties, disable, then stop the services, click apply and then OK.

    Try that see if it helps?
     
  5. chobo2

    chobo2 New Member

    Joined:
    Jun 26, 2009
    Messages:
    40
    Likes Received:
    0
    No it seems abit faster but only by a few seconds. So I will leave it off for now. Any disadvantage of leaving this off?
     
  6. epk1950

    epk1950 Banned

    Joined:
    Sep 1, 2009
    Messages:
    524
    Likes Received:
    9
    There might be like as in if you play world of warcrcraft, some times you need to enable it to use the
    Code:
    ipconfig /flushdns
    cmd to sometimes connect to world of warcraft then disable the service again. Having DNS Client disabled when you have a lot of "active" lines in the hosts file may speed things up.

    Try disabling ipsec policy agent & iphelper services,unless you use em. those are for ipv6.
     
  7. chobo2

    chobo2 New Member

    Joined:
    Jun 26, 2009
    Messages:
    40
    Likes Received:
    0
    Well I don't play WOW or any games at the moment so I guess I don't have to worry. I don't know what ipsec and iphelper are so I don't think I use them.

    It's too bad these did not do anything though. Still as slow as ever.
     
  8. ravenkluk

    ravenkluk New Member

    Joined:
    Feb 2, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem with win7-prof-64bit. I need help too.
     
  9. chobo2

    chobo2 New Member

    Joined:
    Jun 26, 2009
    Messages:
    40
    Likes Received:
    0

Share This Page

Loading...