Local printer connection via ethernet

Discussion in 'Windows 7 Networking' started by CeeGee, Mar 22, 2010.

  1. CeeGee

    CeeGee New Member

    Joined:
    Mar 22, 2010
    Messages:
    14
    Likes Received:
    0
    Hi

    I am trying to set up a HP LaserJet 5000GN printer with a direct wired ethernet connection to my Samsung R519 laptop running Windows 7.

    The printer is checked as compatible with Windows 7 (32 bit), I have the recommended HP Universal Driver installed and the TCP/IP port and printer TCP/IP address set up. The LAN network device is enabled. I did notice that Windows could not detect the printer during the set up routine however.

    When I try to print, the document spools OK in the print queue and the port address is shown however after about a minute, a printing error is shown.

    What am I doing wrong? This arrangement worked fine on my old laptop running Windows XP.

    Regards

    CeeGee
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    On the Win7 machine, open devices and printers
    Select, then right click the problem printer and choose printer properties (near the middle of the context menu, not properties near the bottom)
    Select the advanced tab at the top
    Experiment with different selections,
    If enable bi-directional printing is checked, uncheck that first and see if that helps.
    If that doesn't help, try unchecking enable advanced printing features, if that's an option
    If that doesn't help try selecting, print directly to printer.
    If not of those help, reset them all back to their original settings and
    Select the Ports tab
    Make sure the TCP/IP port and address you are using is selected and then click the configure port button
    Try changing it from RAW to LPR and enter a port name like PORT1 and see if that helps
    Keep us posted.
     
  3. CeeGee

    CeeGee New Member

    Joined:
    Mar 22, 2010
    Messages:
    14
    Likes Received:
    0
    Hi Trouble

    Have tried all the toggles you suggest but no luck i'm afraid. Any other thoughts

    Regards

    CeeGee
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The only other thing I could think of would be to experiment with drivers.
    If you are using the PCL6 driver, then maybe
    Download and install the PS (post script) driver if that doesn't work then
    Download and install the PCL 5 or PCL 5e if the have one.
    Keep us posted.
     
  5. CeeGee

    CeeGee New Member

    Joined:
    Mar 22, 2010
    Messages:
    14
    Likes Received:
    0
    Trouble

    I have tried both the PCL 6 and PCL 5 drivers. The PCL5e driver won't install under Windows 7. Haven't tried the post-script driver. Not sure what a post-script driver will offer me?

    One other thing. When I plug in the ethernet cable, I get an 'Unidentified network' 'No network access' message. The network adaptor is however enabled. Are there any clues here?

    Regards

    CeeGee
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Are all network nodes connected to a common, hub or switch or router with switch ports?
    Can you print a configuration page from the printer, which should show the ip addressing scheme?
    Can you ping the ip address of the printer?
    Does the printer have a built in web interface for setup and configuration?
    " When I plug in the ethernet cable, I get an 'Unidentified network' 'No network access' message." When you plug the ethernet cable into what, you get an Unidentified Network message?
    Have I assumed too much, I was under the impression that you already had a pre-existing viable network that was up and running and that you were now trying to get Windows 7 talking to this network attached printer?
    Perhaps take a couple sentences to describe your network configuration, something like ISP provided device, connected by wire to the WAN port of my (pick your manufacturer)router, with an integrated four port switch, connected to my computer by wire, and my laptop by wireless and my printer by wire, etc.
     
  7. CeeGee

    CeeGee New Member

    Joined:
    Mar 22, 2010
    Messages:
    14
    Likes Received:
    0
    Connecting local printer via ethernet cable

    Trouble

    The printer IP address is 192.168.0.22
    Not sure I know how to ping
    The set up is very straightforward. There is no router or network.
    I have a Samsung R519 laptop. I am connecting an ethernet cable from the laptop to a 10/100m fast ethernet switch then another ethernet cable to the HP LaserJet 5000GN printer. This arrangement works on my old laptop running Windows XP and all the settings in the printer properties dialogue box are the same.

    Here is the ipconfig.txt file. Does this tell you anything?

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : CG-Laptop
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : mshome.net

    Wireless LAN adapter Wireless Network Connection:
    Connection-specific DNS Suffix . : mshome.net
    Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
    Physical Address. . . . . . . . . : 00-24-D2-FF-F6-60
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::6820:2216:8a5d:b30%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.183(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 23 March 2010 12:27:32
    Lease Expires . . . . . . . . . . : 30 March 2010 22:10:22
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 268444882
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-FA-E0-1A-00-13-77-B8-F7-BF
    DNS Servers . . . . . . . . . . . : 192.168.0.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
    Physical Address. . . . . . . . . : 00-13-77-E7-F6-76
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::c4e5:cdd5:22be:ee65%10(Preferred)
    Autoconfiguration IPv4 Address. . : 169.254.238.101(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 167777143
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-FA-E0-1A-00-13-77-B8-F7-BF
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.mshome.net:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : mshome.net
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:73ba:1c08:335c:3f57:ff48(Preferred)
    Link-local IPv6 Address . . . . . : fe80::1c08:335c:3f57:ff48%14(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{1EC98896-78ED-4597-BA74-794DF4FD3DD7}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Regards

    Clive
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, your wireless adapter is on the same subnet as the printer, but the wired adapter is not receiving any IP configuration information.
    Try this
    Type ncpa.cpl into the search box and hit enter
    in the resultant window select and then right click on your wired adapter, should say something like local area connection, then choose properties
    In the resultant page "Local Area Connection Properties" dialog box, uncheck Internet Protocol Version 6
    then Select Internet Protocol Version 4 and click the properties button
    In the resultant page choose the radio button that says "Use the following IP address and then
    enter the following into their respective boxes
    IP address: 192.168.0.247
    Subnet mask: 255.255.255.0 (should and probably will auto populate with that number)
    Default gateway: 192.168.0.1 (since this is an isolated network the default gateway address is probably unneccesary, but it shouldn't hurt anything either)
    DNS addresses you can leave blank or add public DNS servers like
    8.8.8.8 preferred and
    8.8.4.4 alternate again if you're not going outside your subnet to the internet then these are not needed either, but they shouldn't hurt.
    Try that and see if you have any luck
     
  9. CeeGee

    CeeGee New Member

    Joined:
    Mar 22, 2010
    Messages:
    14
    Likes Received:
    0
    Trouble

    OK, that's sorted it out.

    I made the IP changes but didn't bother with the DNS but it seems to work.

    Thanks

    CeeGee
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Excellent, good to know. Thanks for posting back with the update.
     

Share This Page

Loading...