Login ends to explorer.exe crash

Discussion in 'Windows 7 Help and Support' started by Keketti, Nov 17, 2010.

  1. Keketti

    Keketti New Member

    Joined:
    Nov 17, 2010
    Messages:
    8
    Likes Received:
    0
    Hello,

    I've been using Windows 7 x64 for some time now and few days ago it just didn't start anymore. What happens is once I give my password and windows starts to log in it says "preparing your desktop" and after a while says explorer.exe encountered problem and needs to be closed.

    Only safe mode with command prompt works. I've tried sfc /scannow and created new users and tried to log but nothing. Scannow says it fould corrupted files but cant fix it. I checked sfc log by findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >sfcdetails.txt and it's as long as year of famine. I had restore points turned off so no help from there either. I've tried to repair with windows 7 disk but it does nothing. When I press that F8 to get to that menu and choose "repair windows" it ends up in bluescreen.

    I plugged that hard disk on other computer and scanned it with unhackme but it didn't find anything severe and didn't help either. Funny thing is that I shut down computer normally before and nothing indicated that something's wrong. What happened I have no clue. I've spend hours and hours to google if someone else had the same thing but nobody seems to have happen the same thing.

    I'm running out of things what to do so please someone help? And no I don't want to reinstall that damn OS.. I'm not newbie when it comes to computers so you can suggest complicated things also, I just want to get that working.
     
  2. Keketti

    Keketti New Member

    Joined:
    Nov 17, 2010
    Messages:
    8
    Likes Received:
    0
    Spent few hours again trying to troubleshoot with no luck. Just more information:
    Once explorer.exe crashes and I try to restart it by taskmanager - new task, taskmgr.exe crashes.. Hah.

    I runned windows defender through safe mode command prompt and it did find nothing.. I run same computer now with other hard disk with XP installed so I don't think it's hardware issue either. Did memory test and it didn't find anything. Also chkdsk didn't find anything on that hd.
    Here's the log of appcrash if it says anyting:
    Problem event name: appcrash
    Application name: explorer.exe
    Application version: 6.1.7600.16450
    Timestamp: 4aebab8d
    Fault module name: propsys.dll
    Fault module version: 7.0.7600.16385
    Fault module timestamp: 4a5be022
    Exception code: c0000005
    Exception offset: 000000000000b92c
    Os version: 6.1.7600.2.0.0.256.1

    Any help greatly appreciated!
     
  3. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hi.

    Start by booting to safe mode + networking and uninstalling whichever antivirus you have after Googling for its removal tool.

    If that doesn't allow you to boot normally, then reboot to safe mode and uninstall all the lesser known apps and old apps.

    Post your crash dumps and I'll tell ya what's up with them. C:\Windows\Minidump

    Copy the files in there to any other folder then zip them. Attach the zip to a post here.
     
    #3 TorrentG, Nov 17, 2010
    Last edited: Nov 17, 2010
  4. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
  5. Basher

    Basher Honorable Member

    Joined:
    Mar 15, 2009
    Messages:
    367
    Likes Received:
    12
    If WinXP worked on a different HDU, it could be a drive issue - have you tried installing Window7 on the drive you installed XP on?

    Basher
     
  6. Keketti

    Keketti New Member

    Joined:
    Nov 17, 2010
    Messages:
    8
    Likes Received:
    0
    Ok, so there's no antivirus on startup and checked if there's a minidump file. There isn't.. So perhaps my settings are so that it doesn't write it. Tried what Captain pointed also. Used shellexview and disabled all non microsoft shell extensions. Still not work. SFC and new user profile tried also. Can't do repair install in safe mode. Runned registry file also what "Troubleshoot explorer.exe crash" suggest, no luck.

    I think I've had enough of this and admit that seven beat me.

    Btw. Log of that sfc corrupted files is 103 lines long and consists of this kind of lines:
    Cannot repair member file [l:20{10}]"dsound.dll"
    Cannot repair member file [l:22{11}]"propsys.dll"
    Cannot repair member file [l:20{10}]"rasdlg.dll"
    Cannot repair member file [l:26{13}]"sppcomapi.dll"
    Cannot repair member file [l:16{8}]"slui.exe"
    Cannot repair member file [l:26{13}]"sppcomapi.dll", "ShaderCache10.vs_4_0", "Amd64\hpfrsw71.dll", "System.ServiceModel.dll", "imageres.dll" and so on..
    Most of them are mentioned twice so I quess at least 50 files were corrupted.

    I'm thinking that it can't be virus or could it be? It would need to be very very well programmed which I haven't seen anything like in my past 20 or so years with computers..
     
  7. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
  8. Keketti

    Keketti New Member

    Joined:
    Nov 17, 2010
    Messages:
    8
    Likes Received:
    0
    I formatted my OS partition and reinstalled from scratch. Everything is working fine now. At least so far... We'll see will this work for one year before complete breakdown again.. And yes, you can see bit sceptics on my additude. ;)
     

Share This Page

Loading...