Login screen not appearing?

Discussion in 'Windows 7 Help and Support' started by laurence, Feb 3, 2011.

  1. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Hi everyone, first time post here so bear with me :)

    When I boot up my computer, it displays the animated windows7 logo as normal, but where it would normally display the login screen all I get is a blank screen with the mouse cursor. I've tried all keyboard shortcuts and random clicks to no avail - it stays on that screen for hours with occasional HDD activity.

    I've tried booting in safe mode only to encounter exactly the same problem, and have no previous restore points (which I know is a big mistake).

    Due to it not starting in safe mode either, I tried to replace the winlogon.exe file from another Windows 7 instillation to no avail - I still get the same problem.

    I am able to boot into linux (off my removable HDD) and windows XP (from my secondary internal HDD), so I am led to believe it is a corrupted file or dodgy setting within Windows 7 rather than a hardware fault.

    If anyone could shed some light on the situation or suggest what the problem could be, I would be immensely grateful.

    Thanks in advance, Laurence :)
     
  2. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
  3. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Thanks for the reply! I've already done one run-through of that, not knowing 3 are more effective. I'll give that a go tomorrow and let you know how it goes :)
     
  4. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    Hey Captain. Just a question. Would a Windows 7 Recovery disc take care of a situation like that? I have one and that would have been the first thing I thought of.
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would think this would be caused by either a illegal or out of date Win 7 install, a virus, or a video resolution change where you could not see the actual login screen.

    But this Microsoft site lists quite a few reasons for using the repair option.
     
  6. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Hey guys, I've tried using startup repair 4 times (restarts in between, winxp HDD disconnected, partition set to active) and still nothing. From what I can see, it gets past the 'startup' phases as such (windows7 logo), but that still leaves me at a loss as for what to try.

    Saltgrass, my copy is 100% legal (bought directly from Microsoft), and if you mean keeping it updated then I used windows automatic updates to sort that. Obviously a virus is a possibility, although I was incredibly careful with that sort of thing and often ran AVG. With regards to video resolution, the mouse remains normal size, so I don't believe it is that.

    Thanks so much for your help though guys, if you have any other ideas, please let me know :D
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    When you get to the black screen with the mouse, does hitting CTRL+ALT+Del do anything?

    Out of date means the time has expired for activation, but you will normally have options on the screen to let you go ahead and activate.

    The resolution meant is there something about your setup, such as dual screens or a video cable other than a VGA to VGA or DVI to DVI. For instance, are you using an HDMI cable.
     
  8. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Nope, nothing works - I tried all the keyboard shortcuts I know, and I've been using it for almost a year now, so any activation problems should already have shown up. As for video resolution, the mouse cursor displays fine, and my friend's lending me a spare video card in case it's a problem with the card (unlikely, as it boots up in xp). I really don't know what I'm going to do if I can't get this working, a full reinstall is possible but due to prblems with my iPod syncing apps incorrecty, that would involve much more time than I have at the moment :S
     
  9. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
  10. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Hey guys, I just thought I'd report back and let you know that I've finally got it sorted :D. I went into my parallel winXP instillation, and while deleting a file it reported that the recycle bin on my Win7 hard drive was corrupted. I thought I'd investigate a bit further, and deleted the offending folder from the root of my 7 drive. While I was on XP, I reset the permissions on the Win7 drive to grant everyone full access. Bad idea in any other circumstances I know, but I was pretty desperate.

    Anyway, I booted up the Win7 hard drive, and it worked :D. Unsure which fix solved the problem (corrupted recycle bin or permissions), I removed 'Everyone' from the permissions list from within Win7 and restarted.

    Unfortunately, it didn't boot up :(. I simply went into WinXP again and retraced my steps to get it working again, but my system is still running on quite low security :p.

    Anyway, I'm doing a full upgrade to sandy bridge later this month, and I'm going to do a full re-instillation of win7 (64 bit this time) anyway.

    Thanks for your help people :)
    Laurence
     
  11. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I suggest you do some research before you go to Sandy Bridge....
     
  12. laurence

    laurence New Member

    Joined:
    Feb 3, 2011
    Messages:
    13
    Likes Received:
    0
    Are you referring to the chipset fault? I've heard plenty about that, and it does not concern me a great deal - the ASUS board I'll be getting for it has 6 SATA ports, only 3 if which I will use, so I should be good, if I get a faulty one at all. I have done a large amount of research on this, and have decided it's definitly the best bet for me. I'm always happy to discuss this, so let me know if there's anything I need to consider :)
     
  13. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    Besides, they've recalled the bad ones and anything you get since then should be good.
     

Share This Page

Loading...