Windows 10 loss of video when left clicking mouse

drifter00000

New Member
I bought a new gaming computer 2 months ago...when I plugged it in no video...replaced cable to TV...pulled out video card and memory....unplugged a bunch of wires...plugged everything back in carefully....video works....when pressing alt key on keyboard I loose video...got new keyboard...problem solved....bought new logetech trackball mouse....same problem....using old mouse again.....I only loose video when I left click to open something or sometimes when opening new window in firefox...in 10 hours loose video 6 or 7 times...always computer keeps running fine....l have been in calls on skype and I can still hear the conversation when I loose video....installed linux alongside windows....used for about 50 hours so far and never loose video.....when I lose video I have to restart.....when using the computer power button to shut down and restart always have no video....when I use the power supply switch to turn off electricity to computer and then turn it back on....use power button on computer to start....always have video....just wanted to add something that might be helpful.....when I lose video my screen turns black and the familiar circle of white dots is spinning.....but it is spinning very fast and it dosnt say shutting down....just a black screen .....after a few seconds I see just my tv screen saying nothing connected....but computer is still running fine.
asus motherboard
ryzen 7
rtx 3060 nvidia
thanks ahead of time
 
Last edited:

bochane

Excellent Member
You never ever should switch off your computer by removing the power .
The circling dots are shown when your computer starts up. I think you Windows is damaged and needs to being reinstaĺled
 
Top