Making a Folder Public

Discussion in 'Windows 7 Help and Support' started by Chamenas, Dec 20, 2011.

  1. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    [ Solved ] Making a Folder Public

    Edit: This may or may not be better suited in the Networking forums, if it should be there, could a mod move it please? Thanks. Is it possible to make a specific folder in my Win7 installation public? I already have network sharing set-up between my Desktop and my Laptop on my network, but, at the moment, if I want to share something, I have to move it to the Public folder, use it, then delete it from there so that I don't have multiple copies of stuff floating around everywhere. However, I don't want to keep everything on my Window's drive, which means I can't simply move whatever I might be sharing to the Public folder to be used between my Laptop and my Desktop. I'm hoping there's a solution where I can simply share folders that I choose across the network. What I've Tried I've right-clicked on a folder and opened the properties, clicking on the "Sharing" tab. I then went to "Advanced Sharing" and checked off "Share this folder" with the Share name being the folder name, and the path was, by default, set to \\ComputerName\Folder. This made it possible for me to see the folder on my Laptop (I shared one from my Desktop, essentially I'm trying to make my Laptop a satellite for my Desktop, which I'll explain at the end) but when I try opening the folder, my Laptop gets the following error message: "\\ComputerName\Folder is not accessible. You might not have permission to use this network resource. Contact the administrator of this sever to find out if you have access permissions. Access is denied". Great. So I go back and click on "Share" in my folder properties, but the only users listed are the ones found on my computer, not over the network. So I click on the "I'm having trouble sharing" link, which brings up the help. The help mentions "Share with" on the right-click shell menu, so I try that and select Homegroup (Read/Write). Now I'm thinking I've finally done it, since I've now specifically specified that this is what I'm trying to do and granted that specific permission. Back on my Laptop I'm looking at \\ComputerName and I see the folder there still, I try to open it and, voila, same error message. Now I'm stumped. Why Am I Doing This? I'm doing this mostly because my Desktop is the superior computer. It has better storage, etc... (as it should!) so it's the main computer. My Laptop runs Vista (important to mention!) and I like the fact that some of my programs run independently of the main computer, as it lets me do certain things on various websites simultaneously (nothing fishy mind you), which is great. However, for other things, I would like to just run my Laptop as if it was an extension of my Desktop. For instance, I record videos. I'd like to be able to record them on my Laptop if I so choose, but I want them to be recorded right on my Desktop, since it has the better storage. I also like to write, but I don't want multiple versions of stuff on various computers, though I do want the file on my computer somewhere, as opposed to being stored in the cloud. However, I like the freedom of being able to write wherever I might have my computer on the network, so, once again, I'd like to work directly off of the files from my Desktop. I play a text-based game in which I manage a lot of .txt files with stuff I use for the game, same deal as the writing, I might be playing the game on my Laptop instead of my Desktop and I might need to edit or add to those files, but I don't want to be trying to maintain two different folders of those files. I could go on and on, but I think you get the picture of what I'm looking for. I hope it's possible, but I'm unsure.
     
    #1 Chamenas, Dec 20, 2011
    Last edited: Dec 22, 2011
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Are you using passwords to sign in to both computers? Are you using the same username?

    Were able to join a Homegroup and does it show in Windows Explorer?
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Home Group sharing is not supported on downlevel clients (only Windows 7)
    The closest you can come to making a folder "Public" is to set Share (sharing tab) and NTFS (security tab) permissions to full control to everyone group.
    Make sure that both computers are members of the same "Workgroup" Networking home computers running different versions of Windows
    Double check the following on both machines:
    enable NetBIOS over TCP/IP in the properties of IPv4, under the WINS tab, within the properties of your network interface card.
    type
    services.msc
    into the search box and hit enter
    confirm that the following services are started, consider setting the startup type to automatic
    Computer Browser
    Function Discovery Provider Host
    Function Discovery Resource Publication
    Network Connections
    Network List Service
    Network Location Awareness
    Network Store Interface Service
    Server
    SSDP Discovery
    TCP/IP NetBIOS Helper
    Workstation
    Some top tier third party firewall products as well as Anti Virus security suites will cause issues with sharing out of the box, so you will need to either know how to configure them properly to support network sharing and trusts among other network nodes or else uninstall them and replace them with something a lot more networking friendly like Microsoft Security Essentials. In many instances in order to facilitate a complete uninstall of such products it is necessary to run the vendor specific proprietary removal tools. A list of some can be found here http://windows7forums.com/blue-screen-death-bsod/50402-removal-tools-antivirus-software-drivers.html if yours is not present try Google and see if you can find it.
    Regards
    Randy
     
  4. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I couldn't find the WINS tab under the properties for my network card. However, fortunately, just following the steps laid out in the video you gave me did the trick. My problem was that I assumed I could use the Homegroup, but, as you mentioned, apparently that doesn't work, so I just had to make sure they were in the same workgroup and that I was sharing the folder with "everyone". Thanks again :-D
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear that you have managed to sort things out and resolve your problem. Thanks for posting back and updating your thread with that information.
    Hope to continue to see you around the forums.
    Regards
    Randy
     

Share This Page

Loading...