Media Center Lags horribly

Discussion in 'Windows 7 Help and Support' started by HunterJoe, Dec 19, 2009.

  1. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    Hi all,

    New to the forums but not to Windows. I just recently built a new system as an upgrade from HP Elite m9340f Media Center PC. I bought a new Mobo, Video Card and PSU. I used the HDD, RAM, CPU, DVD, and TV Tuner card from the HP in the new build.

    My current specs:
    Gigabyte GA-EP45-UDP3 Mobo
    Socket 775 intel Core 2 Quad Q6700 2.66Ghz
    8MB DDR2 RAM @ 800 Mhz FSB
    ATI Radeon HD 5770 1GB GDDR5 PCIe x16 (CCC 9.11; Driver Version 8.671 - 11/04/2009)
    Hauppauge WinTV HVR-1800 (Model 7800, Combo ATSC/QAM) connected to a PCIe x1 slot (Driver version 1.41.27195 - 7/14/2009)
    Win 7 Pro 64bit (Clean install)

    Everything works great, except Windows Media Center. I have installed the latest drivers from Hauppauge for Win 7, but when I run MC, the video lags my entire system horribly. Every few seconds the video stops then starts up again, and if i run MC as a window and not full screen, then as my mouse moves around the screen it jumps and skips too. The video performance suffers considerably. I have searched the froums here and on the net, but most of the time this problem is mentioned there is no solution given for it. If anyone has any ideas as to how to fix this it would be appreciated.

    Joe.
     
    RAK and (deleted member) like this.
  2. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Have you tried running the media center executable in high or realtime priority?
    Try that out, if it works download a program called "Prio" which will let you save the priority off the executable.
     
  3. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    Thanks for the advice.

    I changed the priorty, but there was no change in the performance.

    Any other ideas?
     
  4. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Are all your media files lagging? Or just one you;re watching on your TV tuner?
     
  5. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    No, not all my media files. I can watch vidoes in Media Player no problem. Only when I use Media CENTER does the lag happen. So I am thinking that it has to do with the TV Tuner also, but I don't know what else to do for it other than the drivers.
     
  6. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    I'll get back to you on this tomorrow.
    If you post the Make and model of your TV tuner I'll look for the newest driver for you.
     
  7. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
  8. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    OK. If this isn't to hard, uninstall your TV Tuner from your computer. (The actual card, not the driver)
    Now see if media center still lags.
     
  9. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    I already took the card out once before, then put it back in with no change. If I take it out and leave it out, then Media Center will not work. It needs to have the card installed in order to receive a signal from the set top box. Nevertheless, I will attempt your suggestion anyway just because you never know...
     
  10. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    OK. you could also try turning off windows media center and then turning it back on but I'm doubtful that would help you.
    To do that Go to control panel>>Programs>>Turn windows features on or off>>Uncheck "windows media Center" under media features, reboot and then turn it back on again.
     
  11. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    You were correct, it didn't change anything.

    What is odd is that if I pause Media Center the lag goes away and the rest of my system functions return to normal (i.e. the mouse dosen't skip across the screen, windows don't jump around when dragged or minimized, etc.). If I let it sit there long enough then it builds up a "que" of time ahead of the program i am watching. When I unpause the program, even though Media Center is playing from the "que"ed up time, it still starts the lag issue.

    I don't think it has anything to do with Media Center directly, but somehow the display drivers or maybe just the video card in general. I used Windows 7 and this version of Media Center in the afore mentioned HP Elite m9340f, with the same TV Tuner. However the video card in that machine was an NVIDIA GeForce 9500 GS 512 MB Card. I had no lag issue with MC using that card. But now with this ATI Card I have this lagging problem. Maybe there are issues with ATI drivers and MC?
     
  12. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    That could be a problem for sure.
    I'm assuming you've got the latest drivers for your ATI card?
     
  13. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    Actually I didn't have the latest drivers... seems a new driver set came out 3 days ago for my series of cards. :) Not that the new set made any difference, but I now can say for sure that I do have the latest drivers for my card.
     
  14. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Who is you Internet Provider? Do you have DSL?
     
  15. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
  16. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Do you know the make/model of your router/modem?
     
  17. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    I am not entirely sure what my router and modem have to do with it. I haven't changed them at all. I already told you that I didn't have this lag issue when using Win 7 and this version of MC on another PC hooked up to this same home network. The only things that have changed from the first PC to this one I am using now is the Motherboard and Video Card, everything else is the same.

    Nonetheless, am using a Zyxel 660 modem provided by my ISP, and an Apple Ariport Extreme router set to bridge mode. I have a static IP on my PC as well.
     
  18. Mitchell_A

    Mitchell_A Excellent Member

    Joined:
    Feb 7, 2009
    Messages:
    5,068
    Likes Received:
    240
    Sorry, i'm very tired right now.
    I'll get back to you in the morning.
     
  19. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    There are newer ATI drivers now. You should download them and see if that fixes anythnig. Do you know how to disable hardware acceleration for the video? This could (maybe) solve it, or make things worse for you.
     
  20. HunterJoe

    HunterJoe Senior Member

    Joined:
    Dec 19, 2009
    Messages:
    25
    Likes Received:
    2
    Hi Mike,

    Yeah I just checked ATI's website and noticed that they put out new drivers on the 17th. I installed them and nothing changed.

    As far as disabling hardware acceleration for the video, I am new to the ATI interface, so I am not entirely sure how do it. :( A little help here would bo great.
     

Share This Page

Loading...