Media Player 12 - "Server execution failed"

Discussion in 'Windows 7 Help and Support' started by voyager, Jun 8, 2010.

  1. voyager

    voyager Honorable Member

    Joined:
    Jun 8, 2010
    Messages:
    34
    Likes Received:
    1
    I've had an ongoing problem with WMP 12 on Win7 x64.
    After playing an audio or video file and then shutting it down, it's been unable to start up again.
    After a long pause, it would give the reason as: "Server execution failed"
    An OS reboot has been the only way to play another audio or video file.
    I saw the thread titled "Windows Media Player 12 issue"
    Code:
    hXXp://windows7forums.com/windows-7-software/28326-windows-media-player-12-issue.html
    [Note the "XX": They won't let me post a working link. I don't have enough posts.]

    Slightly different problem, same result.
    I tried the cure:
    Control Panel\Programs and Features\Turn Windows features on or off\Uncheck all Media Features\Reboot\recheck WMP only.
    Problem solved.
    I can now play a file, shut WMP down, restart it and play another file.
     
    #1 voyager, Jun 8, 2010
    Last edited: Jun 8, 2010
  2. pcs3657

    pcs3657 New Member

    Joined:
    May 6, 2010
    Messages:
    210
    Likes Received:
    13
  3. voyager

    voyager Honorable Member

    Joined:
    Jun 8, 2010
    Messages:
    34
    Likes Received:
    1
    It's now a moot question.
    I've ripped Win7 out and have almost finished the clean reinstall of it and the apps.
    I also ran across a few other "not working as they should" items and decided I didn't want to spend a lot of frustrating time chasing them down too.
    24 hours less a night's sleep, and the reinstall is almost done.
    Everything is now working as it should.
     
  4. PsychoBob

    PsychoBob New Member

    Joined:
    Aug 3, 2010
    Messages:
    4
    Likes Received:
    0
    Bummer you re-installed when all you had to do is this

    1. Click Start, click Accessories, the right click on Command Prompt and choose "run as administrator", then type regsvr32 jscript.dll, and then hit enter.
    2. Type regsvr32 vbscript.dll then hit enter.
    3. Now type exit and hit enter. Now try media player and it should work.
     
  5. voyager

    voyager Honorable Member

    Joined:
    Jun 8, 2010
    Messages:
    34
    Likes Received:
    1
    Thx PsychoBob.
    I'll file that away for future reference if needed.

    The problem has not resurfaced since the OS clean reinstall.
    Plus, all the other niggling not quite right things have gone away along with it.
    I've noted before that sometimes an OS install just doesn't go quite right.
    After it's all done sometimes everything doesn't work as it should.

    The prior Win7 x64 OS install had begun as a dual boot with WinXP Pro x86, then had XP removed.
    I'm no stranger to clean installs.
    I don't like 'em.
    But, I'm not afraid of 'em.
     
  6. dobby121289

    dobby121289 New Member

    Joined:
    Nov 29, 2010
    Messages:
    2
    Likes Received:
    0
    PsychoBob that worked perfectly, i had this problem recently and tried a few other suggestions, and this was the only one that worked :)
     
  7. puman73

    puman73 New Member

    Joined:
    Dec 8, 2010
    Messages:
    2
    Likes Received:
    0
    Hi, i tried to run the regsvr32 jscript.dll command but Wind 7 gave an error code 0x80004005

    Any idea ?
     

Share This Page

Loading...