Microsoft Japanese IME input mapped differently from Vista?

Discussion in 'Windows 7 Help and Support' started by urutapu, Jan 26, 2010.

  1. urutapu

    urutapu New Member

    Joined:
    Jan 26, 2010
    Messages:
    4
    Likes Received:
    0
    Alright, so I'm typing in Japanese for schoolwork, but apparently everything but the letters and numbers is mapped differently when I'm using Microsoft IME. I never had this problem in Vista, where the keyboard wasn't remapped at all. Basically, when I switch to IME, my keyboard inputs like this image: Learn Japanese - How to Type in Japanese

    For example, in Vista IME, typing [ results in [. In 7, [ results in @. And so on.

    Is there any way to remedy this so IME operated like an English-mapped keyboard? I can't figure one out. I'd like to be able to type symbols without have to fish for them.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,838
    Likes Received:
    1,566
    It sounds to me like your using a US keyboard layout, have you tried changing it to something like UK QWERTY ?
    Checkout the screenshot which has arrows pointing out the various settings. If you don't see the keyboard under the list click add.

    View attachment 5076
     
  3. urutapu

    urutapu New Member

    Joined:
    Jan 26, 2010
    Messages:
    4
    Likes Received:
    0
    Okay, I didn't realize UK keyboards were different. Yes, I'm using a US keyboard.

    I don't think changing to a UK keyboard has anything to do with my problem...
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,838
    Likes Received:
    1,566
    Oh well it was just an idea... I also tried google without much success.. Let's hope someone reads this who knows a solution..
     
  5. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    kemical and (deleted member) like this.
  6. Exp HP

    Exp HP New Member

    Joined:
    Jan 9, 2010
    Messages:
    94
    Likes Received:
    6
    This doesn't happen for me. Is this perhaps affected by the KANA lock setting?
    (I think that's supposed to be Shift + Caps Lock, but actually it's not working for me any more... it's just changing the input mode when I do that... argh...)

    Well, when it's off, [ is still [ for me, and shift+2 is still @...
     
    #6 Exp HP, Jan 26, 2010
    Last edited: Jan 26, 2010
  7. neviusaga

    neviusaga New Member

    Joined:
    Feb 2, 2010
    Messages:
    2
    Likes Received:
    0
    I had a similar problem come up just yesterday, maybe my fix will work for you?
    Tell it to Show the language bar, so that you have it going across the top of your window. Change to JPN to display the big list of options (Japanese, IME, Input Mode, etc.) on the far right will be CAPS and KANA buttons stacked one over the other. try adjusting those to see if they will change your keys back to normal. For me, "normal" is both buttons being white. When you activate them they change to blue.

    I think we were having the same problem, here's a better description of mine for clarity/to help other people find it in the future.

    I'd been using JPN input with win7x64 for several months with no trouble on my us keyboard (qwerty/asdfgh). I've been using it this way for several years over other OS's and always use the shift+alt and alt+capslock to change between ENG and JPN and also Romaji and Kana modes. At some point yesterday I hit a key shortcut like that caused it to switch into Japanese keyboard mode. So in english mode I had asdf, in Japanese alphanumeric I still had asdf, but in Japanese hiragana/katakana modes I had
    a = ち 
    s = と
    d = し
    f = は
    which as you can imagine was pretty frustrating considering my US keyboard doesn't have the kana written on it to use in this way. After some trial and error I finally fixed it, my KANA (kana-nyuuryoku) button was activated.
     

Share This Page

Loading...