Microsoft Management Console (MMC) snap-in: "Snap-in failed to initialize

#1
Hi

I recently right clicked my computer and went to manage as I was going to change some drive letters via this process. However i keep getting the following error.

Snap-in failed to initialize.
Name: Computer Management
CLSID:{58221C67-EA27-11CF-ADCF-00AA00Ai0033}

I have found one reference to it on the microsoft web site but this does not appear to help with the problem.

I have tried a system restore to no avail.

Everything else seems to be working fine and I have managed to change the drive letters using a differenct process how ever it is just very annoying when things don't work properly. any advice would be greatly appreciated. I am running windows vista home premium.

Thanks
 


davehc

Essential Member
Premium Supporter
#2
Its not available in the home editions.
 


davehc

Essential Member
Premium Supporter
#3
Its in "Local security Policies" which is not available in the home editions.
 


#4
HI. Thanks for your reply. I am using vista home premium and have used the MMC console in the past. Would have the upgrade to SP1 have disabled it??
 


davehc

Essential Member
Premium Supporter
#5
Sorry. I meant it is the "snap ins" which are not available. The Management console, does not require any snap ins so obviously you should not then see the message.
I see you refer to "manage" so you are accessing through the "Computer" window?
Have you tried through the Control panel (Classic view) Administrative tools
 


#7
Problem Fixed. It turned out to be a corrupt mycomput.dll in windows/system32 folder. I replaced it with one from another vista machine and all is back to nomal. Hope this helps someone else.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.