Midi Controller - Undefined External Error

Discussion in 'Windows 7 Help and Support' started by pooperscoop, Sep 17, 2010.

  1. pooperscoop

    pooperscoop New Member

    Joined:
    Sep 17, 2010
    Messages:
    6
    Likes Received:
    0
    Hello,

    I hope this is the right place to post.

    I am having some I problems with my Akai MPD32 midi controller that I have never experienced before. I use Windows 7.

    I cannot seem to get the MPD32 to send any midi data or be properly recognised in Windows.

    I plug my MPD in by USB and don't see the device connected icon but the MPD is getting power. I've tried running MIDIOX to see if any data is being sent but when I try to select the MPD32 port it says "Undefined External Error". I've looked in Devices & Printers and the MPD is listed there and is apparently working properly but something's really not right.

    I tried on another computer with Windows 7 on and it recognised it. I installed MIDIOX and was able to select the MPD input but the monitor was not showing any data at all.

    I thought maybe it was the USB cable so I went to my local internet cafe to see if they had any but they didn't, although they did use my cable on a printer to test it and it was working fine.

    Now I'm completely lost and don't know what to do. What does this error mean, I can't find much about it on the internet. This midi controller used to work and I don't know what has happened to it now.
     
  2. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    I haven't worked with this exact model, so forgive me if I get some of the finer points wrong...

    1) Is the USB port enabled in the controller... the ones I worked with had a setting for that.

    2) are you sure the controller is sending?

    About the only other suggestion I can give you is to uninstall and re-install it's drivers.
     
  3. pooperscoop

    pooperscoop New Member

    Joined:
    Sep 17, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks for the reply.

    1) I have been through the menus and manual and I can't see any way to select or change it to USB mode, I think it just works automatically.

    2) The device is definitely getting picked up by Windows, I can see it in the Devices & Printers page but it doesn't seem to be sending any midi data over. I can see the ports in a few programs but I am not able to use them.

    One of the programs I use, Vysex Editor, says that the USB port is already in use. Now, this editor is designed especially for this program and their troubleshooting manual saus that there can be issue with Logitech webcams. I have a integrated webcam on my Inspiron but I don't think it's a Logitech. ANyway, I tried to uninstall it and it made no difference and just installed itself again when I rebooted.

    I have nothing else plugged in to the laptop. I just found a utility called USBDeview, which lists all the devices used previously and in use at the moment. It says that my Realtec card reader is in use (nothing in there at the moment) and that a USB Composite Device is in use. I have nothing plugged in.

    I think this could be the problem. It seems that something is interfering with the USB port and somehow 'using' it. I have tried other ports but no difference. How can I find out what this phantom thing is? I don't want to start uninstalling things randomly just to try to find it in case I mess up my computer.

    I also thought maybe it was something to do with the midi device limit that used to (and some say still does) exist. However, I removed them in the registry so that shouldn't be a problem now, even if it was.
     
  4. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Rather than uninstall stuff, go into the device manager, locate the device, right click on it and select properties and uncheck the "Use This Device" option... essentially disabling it. Do this one at a time until you are sure there are no device collisions. Some poorly written USB drivers will hook other (similar) devices by mistake.

    Don't know if this is the answer, but it is a worthwhile experiment to try.
     
  5. pooperscoop

    pooperscoop New Member

    Joined:
    Sep 17, 2010
    Messages:
    6
    Likes Received:
    0
    I can't see the option you mention but I've just been trying to disable things but no luck so far.

    This is the device manager at the moment. I have the MPD32 plugged in and have tried to disable the card reader and the extra 'USB Composite Device', whatever this is. The webcam is also disabled. But there's really not much to disable, as you can see it's all fairly basic and standard things.


    devman.

    And this is the screen print of the USBDeview with the mysterious USB Composite device details open, I don't know if it gives any new information.

    usbdeview.
     
    #5 pooperscoop, Sep 18, 2010
    Last edited: Sep 18, 2010
  6. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    That "composite device" doesn't seem to have drivers installed...
    Have you checked that the dirvers for your controller are installed and working?
     
  7. Bumblebee001

    Bumblebee001 New Member

    Joined:
    Oct 10, 2010
    Messages:
    6
    Likes Received:
    0
    I have been experiencing the same issue exactly since around the same time as the previous complainant.

    I tried a different keyboard, different cables (2 of the same make and another of different make). On each occasion cable is recognized but software does not react to the input from the keyboard. Midi-Ox, Midimedic, 2 different music software all fail to pick up midi signals. Re-installation of drivers fails to improve matters.

    I am using Windows 7 64 bit. The situation is most frustrating! Windows 7 does not allow me to restore back to the time the issue surfaced as unlike previous windows versions, Restore goes back only 10 days, to the beginning of the month! I call this regress not progress!
     
  8. Bumblebee001

    Bumblebee001 New Member

    Joined:
    Oct 10, 2010
    Messages:
    6
    Likes Received:
    0
    I solved the issue by purchasing and installing an M-Audio midisport 1x1 interface. It installed without any difficulty (online driver for Windows 7) and allowed me to play the MIDI keyboard. It should be noted that re-installation of Windows 7 and all the programs and drivers did not solve the issue I was experiencing with generic MIDI-USB cables even though the "undefined external error" was gone.

    I think the issue is a driver incompatibility issue with Windows 7 and/ or a bug with this OS that has yet to be addressed. Initially these cables may function for a while but sooner or later, possibly with windows auto-updates, drivers become corrupted and therefore useless. No amount of attempts at re-installing the drivers will be met with success.
     

Share This Page

Loading...