Missing Operating System

#1
Hey everyone. First off, Happy New Year! Feels good to be done with 2009 and have a fresh start :]
That being said, I'm havig trouble with my operating system and was hoping someone here could help me out.

I received a Missing Operating System error message upon boot and have unsuccessfully tried to change the hd0 setting in the BIOS. However, maybe my problem lies somewhere else...

Lemme explain the situation, and I'm going to try and be as descriptive as possible:
I have a Windows Vista computer by default and upgraded to Windows 7.
I then installed Fedora 11 as a dual-boot and eventually ran out of space, so I wanted to delete it. Problem is, I knew that deleting the Linux partition would have mixed up the MBR order so I burned an ISO of Windows 7 Recovery Disk in preparation of fixing the MBR. I decided to test it out and explore before actually deleting the partition.
So this is where I screwed up:
-Booted to CD, Windows loads files.
-System Recovery Options window pops up > Next
-Two options appear:
(1) Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. (there is nothing listed)
(2) Restore your computer using a system image that you created (which doesn't really apply to me)
-Then two buttons: Load Drivers and Next>
-I selected the first option "Use recovery tools.." and click Next
-The following options appear:
Startup Repair
System Restore
System Image Recovery
Windows Memory Diagnostic
Command Prompt
-I click Command Prompt and type: bootrec.exe/FixMBR, then Enter
-It says complete and I reboot. This is where the error message comes in and I am totally lost as to how I should approach this. I am guessing the error happened when I did not choose an operating system and executed a command, leaving the computer unable to find Windows 7.

Please help if you can! Thanks :]
 


Trouble

Noob Whisperer
#2
you can try this

bootrec.exe /fixboot
and then
bootrec.exe /fixmbr
and restart.


Probably not going to make it any worse, I'm guessing your current error situation stems from your Fix Master Boot Record command pretty much hosing Grub or whatever Fedora calls it's boot loader, so I can't really say that this will help, but I guess it's worth a try.
 


#4
Drew:
I am unable to provide a screenshot of disk management at this time, but I suppose I will have to run a clean install if worse comes to worse (btw, upgraded to 7 with a download and not with an actual disk, so I'm not entirely sure on how to go about that. Will look into it.)
And I've tried running the startup repair tool, but it leaves me with "Startup Repair cannot repair this computer automatically" and suggests that I send info to Microsoft (which is pretty much a dead end at this point lol)

Trouble:
Tried the "bootrec.exe/fixboot" and got "This volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted."
Then tried "bootrec.exe/fixmbr" and got "The operation completed successfully" So I'm assuming the problem started when I didn't select an OS at the start of running the program. I'll check out that article in the meantime. Hopefully I'll find something helpful unique to my problem.

Any othr suggstions?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.