Mosue Stopped Working

Discussion in 'Windows 7 Help and Support' started by vahnx, Jan 14, 2009.

  1. vahnx

    vahnx New Member

    Joined:
    Oct 25, 2006
    Messages:
    132
    Likes Received:
    0
    Mouse Stopped Working

    I rebooted from XP to 7 today and my mouse stopped working. I heard the USB Device sound like when you plug in a device when I booted, when I got to the machine my mouse was lit, everything worked except the USB mouse. I unplugged it and plugged it back in and it still didn't work. I plugged it into a diff USB port and it worked. I plug it back into the other port it doesn't work but other devices in that port work. I assume if I reboot or remove the USB devices from device manager and let Windows auto-detect, it will be fixed, but why is this happening?

    Solved: Went into the device manager and under Mice it showed Unknown Device, so I right clicked and Enabled it.
     
    #1 vahnx, Jan 14, 2009
    Last edited by a moderator: Jan 21, 2009
  2. vahnx

    vahnx New Member

    Joined:
    Oct 25, 2006
    Messages:
    132
    Likes Received:
    0
    Edit: The past few days my mouse stopped working again and right->click enabling doesn't fix it. have to resort to using my cordless USB one which isn't the best for gaming. And yes I have XP for gaming, but I am beta testing 7 so I like to game in it aswell.
     
    #2 vahnx, Jan 21, 2009
    Last edited by a moderator: Jan 21, 2009
  3. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Sounds liked a bad mouse driver. What is the make and model of your mouse?
     
  4. vahnx

    vahnx New Member

    Joined:
    Oct 25, 2006
    Messages:
    132
    Likes Received:
    0
    Um it's a Creative... doesn't say. Worked fine before, until I heard that sound the one day. Re-installed driver, uninstalled/installed, disabled,enabled, etc. Doesn't work. PS Works fine in XP/Ubuntu/Any other OS w/ plug 'n' play

    PS Sorry cannot change title for some reason, mis-spelled mouse
     
    #4 vahnx, Jan 21, 2009
    Last edited by a moderator: Jan 21, 2009
  5. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Well it is definitely a driver issue then. I am sorry i cannot help until i have more info about the mouse. I would check the manufacturers website for the latest vista driver and install it.
     
  6. vahnx

    vahnx New Member

    Joined:
    Oct 25, 2006
    Messages:
    132
    Likes Received:
    0
    OK I just looked at the bottom of the mouse. It's a
    Creative Mouse Optical Lite
    Model No: OMC90S

    I'll Google for a driver (if I can find one), test it and report back next time I boot into 7.

    Creative no longer has drivers for my model, and I can't find any on the internet =(

    Edit: Rebooted and enabled it again in device manager and now it's working. I have a feeling it will stop working again though =S
    Hope M$ fixes this before they RTM.
     
    #6 vahnx, Jan 21, 2009
    Last edited by a moderator: Jan 21, 2009
  7. Iggy82

    Iggy82 New Member

    Joined:
    Feb 19, 2009
    Messages:
    2
    Likes Received:
    0
    Same problem

    I have exactly the same problem, the mouse only works after I choose to restart my system from the Windows 7 desktop. I've tried loading the correct driver for the mouse rather than the generic driver that is pre-installed into Windows but the same problem still exists. The next time I go to use my laptop, the problem re-appears.

    I'm using a Lenovo N200 3000 series laptop 0769 BWG
     

Share This Page

Loading...