MS Wireless Mouse 5000 causes FSX to fail

#1
I have just upgraded my mouse from a MS Wireless Intellimouse Explorer 2.0 to a MS Wireless Mouse 5000.

However, when I start my favourite application (Flight Simulator X), it fails to load properly, and produces a non-specific application error. Looking at the Event Viewer in Admin Tools suggests the problem lies with HID.DLL :
Description:
Faulting application name: fsx.exe, version: 10.0.60905.0, time stamp: 0x44fd0a92
Faulting module name: HID.DLL, version: 6.1.7600.16385, time stamp: 0x4a5bd9ec
Exception code: 0xc0000005
Fault offset: 0x00001a3b
Faulting process id: 0x328
Faulting application start time: 0x01cb5aa29bb562bc
Faulting application path: C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\fsx.exe
Faulting module path: C:\Windows\system32\HID.DLL
Report Id: db6b1bbd-c695-11df-af62-20cf30897e90
If I swap my mouse back to the old Intellimouse Explorer, the application loads fine.

To try to get the mouse 5000 to work with FSX, I have changed the 'connected device' in the Mouse/Buttons tab to the Intellimouse Explorer. But this hasn't worked. I have also tried the latest drivers etc...

Any thoughts on how I can resolve this issue, short of abonding my new mouse, would be really great.

Many thanks,

Alex Berry

(Windows 7 Home Premium, 64-bit; Intel i5-760, Asus P7P55D-E LX, 4Gb DDR3 RAM, ATI Radeon HD 5550 512Mb GDDR3)
 


Last edited:
#2
Maybe FSX needs to re-initialise to adapt to the new mouse? - maybe ask in an SFX specific forum
 


#3
Simple: There's an access violation.

Uninstall the software and driver completely. Reboot and run Ccleaner to clean the registry.

Then install the latest driver from MS' site.
 


#4
Thanks for all your suggestions. I'll give it another go when I get home later, otherwise I might have to cross over to Logitech for a change and maybe even abandon the whole wireless mouse and go back to the good-ol' wired mouse.

TorrentG, you mention CCleaner to clean to registry. I already have TuneUp Utilities 2010, which includes a registry cleaner. Will this do, or does CCleaner hold a particular advantage?

Would it be worth trying the 32-bit version of Intellipoint 8.0 on my 64-bit Win7 system? (Would the 32-bit version even work; I don't know..?)

Thanks,
 


#5
I give my advice exactly as intended 100% of the time. Good luck. :)
 


#6
Thanks for your help, everyone.

Unfortunately, it hasn't worked. Latest drivers, everything.

So, I attached a new Logitech (M305) mouse to the PC. Once again, the same problem occurred; FSX fails to start with an error in HID.dll.

I have come to the conclusion that the problem can't lie with the mice, but it must be something with my Windows installation. HID.dll is a windows file.

So, I'm going for the complete format and reinstall of Windows 7 approach... Bye for now...

Alex.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.