MSI Files crashes on startup

Discussion in 'Windows 7 Help and Support' started by Banzai!, Jan 17, 2009.

  1. Banzai!

    Banzai! New Member

    Joined:
    Jan 11, 2009
    Messages:
    28
    Likes Received:
    0
    Hi, gonna keep it simple.. I cant install my Adobe Photoshop CS2, when i start the msi installer the program just "stop working" so the send to windows message pops up... Anyone know how to fix this?
     
  2. L0tR

    L0tR New Member

    Joined:
    Jan 18, 2009
    Messages:
    6
    Likes Received:
    0
    I have the same problem, can't install Visual Studio because of this.

    Well, in fact I can't install anything using windows installer:(
    I tried downloading different versions from microsoft.com but none of them installed.
    Strange, that few people have such problems...
    PS: running build 7000, x64.
     
    #2 L0tR, Jan 18, 2009
    Last edited: Jan 18, 2009
  3. RMT

    RMT New Member

    Joined:
    Jan 17, 2009
    Messages:
    28
    Likes Received:
    0
    1/2
    i used option 1 and i now have 0 errors on msi installers

    1
    start regedit
    navigate to HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions
    rename MachineThrottling to _MachineThrottling

    or
    1

    Many users have started experiencing random crashing of explorer and msiexec.exe when trying to start Windows Update or install anything that uses an MSI based installer. This issue is bad enough that some people have even formatted because of it, only to have it come back again.
    Rafael has discovered that the fault lies with the SQM Client which is part of the Customer Experience Improvement Program. It seems that ANY process that calls WinSqmStartSession in ntdll.dll will start crashing when MachineThrottling is enabled in the registry, which seems to happen as a result of CEIP running.
    There are two workarounds for this issue. One may only be temporary, while the other should be permanent. I will list the permanent method here so everyone can cure the issue once and for all.

    1. Delete the string values (Except for (Default)) in HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions
    2. Start gpedit.msc
    3. Expand Computer Configuration, expand Administrative Templates, expand System, expand Internet Communication Management, and then click Internet Communication settings.
    4. In the details pane, double-click Turn off Windows Customer Experience Improvement Program, and then click Enabled.

    Yes, doing the above WILL disable the anonymous usage data (CEIP), but until Microsoft fixes the issue and issues a hotfix or a new build I don’t see any other options to ensure the issue does not occur again.
     

Share This Page

Loading...