My Dell Studio 1558 will not recognize my 1tb Simpledrive anymore.

Hi everyone. I'm sure this is going to seem completely shocking, but I'm having a problem with Windows 7 and my 1tb Simple Tech Simpledrive usb external hard drive. I've used the search feature on this forum and have tried the recommended remedies for this, such as renaming my dvd drive, and nothing has worked so far. I started having this issue about a month ago sporadically but have been able to work around it by just shutting down the laptop, unplugging and replugging the Simpledrive and starting it up again.

Some interesting facts:

- The Simpledrive is recognized by other computers.

- The Simpledrive lights up and hums when connected to this computer.

- From what I'm seeing, the Simpledrive is nowhere to be found under My Computer. I don't think the ST9500420AS ATA Device listed under disk drives in the device manager (pictured below) is my external drive, but I could be wrong about that.

- The usb ports are all functioning properly. I can plug other devices into the same port and all the other ports and the laptop will recognize them.

- Formatting my Simpledrive is not an option as I have data on there that I cannot afford to lose.

Here are my specs:

Dell Studio 1558

Windows 7 Home Premium

Intel(R) Core(TM) i3 CPU M33 @ 2.13 ghz 2.13 ghz

4g RAM

64 bit OS

Here is a snapshot of my device manager if that helps.

Any help would be appreciated. This laptop is a replacement Dell sent me because they failed to resolve this very issue along with my function keys not working. Protip: Don't ever buy a Dell.

Thank you in advance.

Hello and welcome to windows7forums.

Right click computer -> Management -> Disk manasgement -> Create partitions and format to NTFS.

Please let know if you need more help.

Hi. This should be a fairly simple fix. Here's how:

1. Click on START button.
2. Type REGEDIT and press Enter.
3. When REGEDIT starts, open up the following key:
4. After clicking on {4D36E967-E325-11CE-BFC1-08002BE10318} you should see two settings on the right-hand side:
Click on each of them, press DELETE and click YES.


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.